The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem : FTP upload adds 4 hours to the current time !

Discussion in 'General Discussion' started by mpierre, Aug 27, 2003.

  1. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Hello, when my clients upload a file via FTP, the file time on the server is 4 hours in the future !!! ( I tested it myself... )

    Yet, the server has the proper time,

    and worse,my client, my computer AND the server are in the SAME timezone : EDT.

    When the file is downloaded, it keeps the same filetime ( the one 4 hours in the future... ).

    Via SCP ( over SSH ), there is NO problems !

    Has anyone got an idea ?

    cPanel.net Support Ticket Number:
     
  2. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    What FTP client are they using? It's very likely converting the time to UT, which can be changed in the FTP client itself to display actual server time. In WS_FTP this used to be in the time offset field on one of the tabs (advanced?).

    cPanel.net Support Ticket Number:
     
  3. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Indeed, WS_FTP shows all the dates 4 hours in the future !!!

    The Timeoffset thought, it 0.

    This means that it thinks that the file time is on UTC, even thought it is already in EDT.

    Is there anything I can do about that on my side ?

    cPanel.net Support Ticket Number:
     
  4. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Setting a time offset of -4 solves the problem...

    But it shouldn't be required, no ?

    cPanel.net Support Ticket Number:
     
  5. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    No, it means that WS_FTP (with a time offset off 0) is correctly modifying the results it ouputs for the timestamps, based on the server time. Applying the offset within the FTP client takes care of the issue off matching the timestamps to server time (or to the timezone where the client happens to be). This is fairly standard with some applications andd is competely normal.

    cPanel.net Support Ticket Number:
     
  6. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    I honestly don't agree...

    A ) it should not be up to the client to correct this problem

    b ) not all FTP clients have this option...

    cPanel.net Support Ticket Number:
     
  7. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    Then I suppose you'll need to take it up with the developers of whatever application is in use. Whether you agree or not, this is the way some FTP applications work (especially WS_FTP, which has been like this forever), and the solution is to adjust the time offset to match whatever the user thinks they want to see.

    cPanel.net Support Ticket Number:
     
  8. Miss Jacky

    Miss Jacky Well-Known Member

    Joined:
    Mar 4, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    I seem to have the same problem, although in my case the ftp server time is 2 hours in the past... (server is CET)

    Did you ever found a sollution for this mpierre? I agree with you that it should not be up to the client to correct this, surely this can be taken care off on the server?
     
  9. Miss Jacky

    Miss Jacky Well-Known Member

    Joined:
    Mar 4, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Found this in proftpd.org faq:

    So as you can read above, in etc/proftpd.conf somewhere in the beginning

    TimesGMT off

    (+ restart ftp server)

    and my problem was solved, hope this may help somebody else some day.
     
Loading...

Share This Page