The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem IMAP & Webmail Login

Discussion in 'E-mail Discussions' started by Sisnetworks, Oct 26, 2008.

  1. Sisnetworks

    Sisnetworks Registered

    Joined:
    Aug 23, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hello again,

    I have a problem with Imap on my server. The customers gets the error that on the below when they login to Webmail;
    PHP:
    Warning:  fsockopen() [function.fsockopen]: unable to connect to localhost:143 (Connection refusedin /usr/local/cpanel/base/3rdparty/squirrelmail/plugins/login_auth/functions.php on line 129
    /scripts/restartsrv imap when i type this imap commands i got these errors;

    Code:
    server# /scripts/restartsrv imap
    Waiting for imap to restart..............finished.
    
    root     72333  0.0  0.0  3104   828  ??  S     9:48PM   0:00.00 /usr/local/sbin/courierlogger -pid=/var/run/pop3d-ssl.pid -start -name=pop3d-ssl /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 995 /usr/local/bin/couriertls -server -tcpd /usr/local/sbin/pop3login /usr/local/bin/pop3d Maildir
    root     72334  0.0  0.1  3128  1100  ??  S     9:48PM   0:00.00 /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 995 /usr/local/bin/couriertls -server -tcpd /usr/local/sbin/pop3login /usr/local/bin/pop3d Maildir
    root     72346  0.0  0.0  3104   828  ??  S     9:48PM   0:00.00 /usr/local/sbin/courierlogger -pid=/var/run/pop3d.pid -start -name=pop3d /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 110 /usr/local/sbin/pop3login /usr/local/bin/pop3d Maildir
    root     72347  0.0  0.1  3128  1100  ??  S     9:48PM   0:00.00 /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 110 /usr/local/sbin/pop3login /usr/local/bin/pop3d Maildir
    
    imap has failed, please contact the sysadmin (result was "authdaemond is not running").

    even if i run authdaemond with manuel, i get the errors always.

    I am waitng for your help..
    Regards..
     
  2. sjackson909

    sjackson909 Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Columbus, OH
    Running into the same error messages. running FBSD 6.4 with WHM 11.23.2 cPanel 11.23.6-S27698. I have ran /scripts/upcp --force also restart pop3 and imap with no luck! Anyone have any ideas?

    Thanks
     
  3. sirotex

    sirotex Well-Known Member

    Joined:
    Jul 10, 2008
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    I have already answered this question on another thread. Please try looking through threads before asking. Anyways, in a latest update in WHM it updates IMAP to a newer version, thus you need to enable IMAP in the 'IMAP Configuration' (in cPanel 11.24.x its now named 'Mailserver Configuration')
     
  4. k3oni

    k3oni Member

    Joined:
    Nov 2, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Somewhere is USA
    Double post!
     
    #4 k3oni, Nov 21, 2008
    Last edited: Nov 21, 2008
  5. k3oni

    k3oni Member

    Joined:
    Nov 2, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Somewhere is USA
    This does not help with anything in at least 2 cases i've seen so don't jump on people because they opened a new thread.. as many things don't work as posted. Some things work for some but not for all.



    Check /etc/rc.conf for the following lines:

    courier_imap_imapd_enable="YES"
    courier_imap_imapd_ssl_enable="YES"
    courier_authdaemond_enable="YES"

    If this lines are not there or showing differently modify them or add them to look like that.

    After that try and start/restart courier.
     
    #5 k3oni, Nov 21, 2008
    Last edited: Nov 21, 2008
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    A note on the '--force' usage. That flag does not get propagated to all the scripts upcp calls, for example /scripts/courierup. Thus, if your goal is to force an update of courier, run

    /scripts/courierup --force

    As for the failures:

    1. Is the Courier Port verified installed?
    2. Anything logged to a system log?
    3. What happens when you use the init script, rather than the restartsrv script?
    4. What happens when you execute the imap binary directly?
     
  7. inda

    inda Member

    Joined:
    Dec 28, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1

    Hello

    add manually this lines to /etc/rc.conf
    work fine for me,
    os: freebsd6.3

    courier_imap_imapd_enable="YES"
    courier_imap_imapd_ssl_enable="YES"
    courier_authdaemond_enable="YES"

    Thanks You k3oni
     
  8. mahinder

    mahinder Well-Known Member

    Joined:
    Jun 12, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    matrix


    i am having same problem, your advice did fixed my problem for some time but now its back.

    i think i have to find other solution

    edit: i found the problem it was due to my firewall blocking more then 100 connection and not due to something else.
     
    #8 mahinder, May 28, 2009
    Last edited: May 28, 2009
Loading...

Share This Page