The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem in amavis + spamassasin

Discussion in 'General Discussion' started by capecod, Mar 26, 2004.

  1. capecod

    capecod Registered
    PartnerNOC

    Joined:
    Dec 30, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Acutually, my admin considers how to embed spamassasin into amavis. However, the following loop has been made if the comment-outs are removed.
    In fact, exim is regarded as a outer command by amavis.
    Anybody knows how to avoid any loop in the combination of amavis and spamassasin. Thanks.

    begin routers

    jwhavsys:
    driver = manualroute
    condition = "${if or { {eq {$interface_port}{10025}} {eq
    {$received_protocol}{scanned-ok}} } {0}{1}}"
    # domains = +local_domains
    transport = jwhavsys
    route_list = "* localhost byname"
    self = send

    #virtual_sa_user:
    # driver = accept
    # headers_add="${perl{gensaheader_virtual}{$domain}}"
    # condition =
    "${perl{checksa_deliver}{$domain}{$local_part}{$received_protocol}}"
    # domains = lsearch;/etc/userdomains
    # retry_use_local_part
    # transport = virtual_sa_userdelivery

    #sa_localuser:
    # driver = accept
    # check_local_user
    # headers_add="${perl{gensaheader}{$local_part}}"
    # condition = "${perl{checkusersa}{$local_part}{$received_protocol}}"
    # domains = ! lsearch;/etc/userdomains
    # transport = local_sa_delivery
     
Loading...

Share This Page