crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
0
66
Problem in cPanel x3 theme

I am able to login in the cpanel of any cpanel account but i am not able to access anything like File Manager, PHPmyadmin, etc.

please check attached screen shot for your reference.

I had rollaback to theme x & it works then what is the problem in theme x3 ?

We are running as below
cPanel 11.25.0-S43473
WHM 11.25.0 - X 3.9
CENTOS 5.5 i686 virtuozzo
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,544
11
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
Problem in cPanel x3 theme

I am able to login in the cpanel of any cpanel account but i am not able to access anything like File Manager, PHPmyadmin, etc.

please check attached screen shot for your reference.

I had rollaback to theme x & it works then what is the problem in theme x3 ?

We are running as below
cPanel 11.25.0-S43473
WHM 11.25.0 - X 3.9
CENTOS 5.5 i686 virtuozzo
Try running a /scripts/upcp --force and try once again.
The specified version of cPanel is significantly out-of-date. I agree with what JeffMonte has suggested in that it is a good precautionary measure to ensure the system is updated to the latest build. The following page shows the latest build for each build tree: Latest cPanel/WHM Builds

The following command may be used to perform a full update (via root SSH access):
Code:
# /scripts/upcp --force
I've forget attachment
Is the issue affecting only one user account, or are you experiencing the same issue on multiple cPanel accounts?

Are you using a customized branding package or style for the cPanel X3 theme?

Have you performed any modifications to the cPanel X3 theme?
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,544
11
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
Is the issue affecting only one user account, or are you experiencing the same issue on multiple cPanel accounts?

Are you using a customized branding package or style for the cPanel X3 theme?

Have you performed any modifications to the cPanel X3 theme?
In addition to my initial questions, please also test cPanel X3 using different browsers. I see the screenshot is using Google Chrome; I recommend trying other browsers for testing purposes such as Mozilla Firefox, Opera, and Apple Safari or WebKit, all of which are available for both Windows and Mac.
 
Last edited:

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
0
66
The specified version of cPanel is significantly out-of-date. I agree with what JeffMonte has suggested in that it is a good precautionary measure to ensure the system is updated to the latest build. The following page shows the latest build for each build tree: Latest cPanel/WHM Builds

The following command may be used to perform a full update (via root SSH access):
Code:
# /scripts/upcp --force


Is the issue affecting only one user account, or are you experiencing the same issue on multiple cPanel accounts?

>> Yes, we are experiencing the same issue on multiple cPanel accounts

Are you using a customized branding package or style for the cPanel X3 theme?

>> No, we are using a style for the cPanel X3 theme

Have you performed any modifications to the cPanel X3 theme?
>> No , We didn't performed any modification to the cPanel X3 theme since VPS bought
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,578
52
308
cPanel Access Level
Root Administrator
>> No , We didn't performed any modification to the cPanel X3 theme since VPS bought
Try rebuilding your locale databases. Via the command line execute:

Code:
# /usr/local/cpanel/bin/build_locale_databases --build

Also is there anything logged to /usr/local/cpanel/logs/error_log ?
 

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
0
66
In addition to my initial questions, please also test cPanel X3 using different browsers. I see the screenshot is using Google Chrome; I recommend trying other browsers for testing purposes such as Mozilla Firefox, Opera, and Apple Safari or WebKit, all of which are available for both Windows and Mac.
I've tried in different browsers but i am seeing same problem in all other browsers to

I've attached screen shot for your reference.
 

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
0
66
[checkperlmodules] The perl module DateTime could not be installed.

The following command may be used to perform a full update (via root SSH access):
Code:
# /scripts/upcp --force
I ran this command & than i received mail regarding checkperlmodules] The perl module DateTime could not be installed.

This module is required by cPanel, and the system may not function correctly until it is installed, and functional. Below is the results of the auto-install attempt:

Test Run
==============
Can't locate List/MoreUtils.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /usr/lib/perl5/site_perl/5.8.8/DateTime/Locale/Base.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/DateTime/Locale/Base.pm line 8.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/DateTime/Locale.pm line 10.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/DateTime/Locale.pm line 10.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/DateTime.pm line 46.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/DateTime.pm line 46.
Compilation failed in require at - line 1.
BEGIN failed--compilation aborted at - line 1.


Installer Run
==============
Testing connection speed...(using fast method)...Done
Ping:0 (ticks) Testing connection speed to cpan.belfry.net using pureperl...(157050.00 bytes/s)...Done
Ping:0 (ticks) Testing connection speed to cpan-du.viaverio.com using pureperl...(157700.00 bytes/s)...Done
Ping:0 (ticks) Testing connection speed to mirrors.24-7-solutions.net using pureperl...(103966.67 bytes/s)...Done
Three usable mirrors located
Mirror Check passed for cpan-du.viaverio.com (/index.html)
commit: wrote /usr/lib/perl5/5.8.8/CPAN/Config.pm
CPAN: Storable loaded ok
Going to read /home/.cpan/sources/authors/01mailrc.txt.gz
Going to read /home/.cpan/sources/modules/02packages.details.txt.gz
Database was generated on Fri, 06 Aug 2010 00:27:57 GMT
CPAN: HTTP::Date loaded ok


There's a new CPAN.pm version (v1.9402) available!
[Current version is v1.7602]
You might want to try
install Bundle::CPAN
reload cpan
without quitting the current session. It should be a seamless upgrade
while we are running...


CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
http://cpan-du.viaverio.com/modules/03modlist.data.gz
Going to read /home/.cpan/sources/modules/03modlist.data.gz
Undefined subroutine &Compress::Zlib::gzopen called at /usr/lib/perl5/5.8.8/CPAN.pm line 5721.
 

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
0
66
The following command may be used to perform a full update (via root SSH access):
Code:
# /scripts/upcp --force
I ran this command & than i received mail regarding checkperlmodules] The perl module DateTime could not be installed.
I've done below & fixed this issue
Code:
cd /usr/local/src
wget layer1.cpanel.net/perl588installer.tar.gz
tar -xzvf perl588installer.tar.gz
cd perl588installer
./install -optimize-memory

/usr/local/cpanel/bin/checkperlmodules
/usr/local/cpanel/startup
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,544
11
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
I've done below & fixed this issue
Code:
cd /usr/local/src
wget layer1.cpanel.net/perl588installer.tar.gz
tar -xzvf perl588installer.tar.gz
cd perl588installer
./install -optimize-memory

/usr/local/cpanel/bin/checkperlmodules
/usr/local/cpanel/startup
Thank you for the follow-up sharing your resolution information.

At any time did you also run the following command (via root SSH access), as mentioned by cPanelKenneth?
Code:
# /usr/local/cpanel/bin/build_locale_databases --build
If you executed the aforementioned command:
  • Did it result in any visible changes to what you were experiencing while using the cPanel X3 theme?
  • Was it ran before or after Perl was recompiled/reinstalled?
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,544
11
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
No, I didn't ran the above command.
Thank you for letting us know; I appreciate the extra detail as it helps us to better understand the full scope of corrective measures that were attempted.