The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem in forward pipes, "local delivery failed"

Discussion in 'General Discussion' started by zeez, Jan 13, 2010.

  1. zeez

    zeez Registered

    Joined:
    Jan 13, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have cPanel 11.25.0.
    I am trying to forward an email address to a pipe.
    I tried the following inputs into the pipe field

    1. /public_html/file.php
    2. /home/user/public_html/file.php
    3. /usr/local/bin/php -q /home/user/public_html/file.php
    4. /usr/bin/php -q /home/user/public_html/file.php

    My script has #!/usr/local/bin/php -q before <?php.

    file.php has chmod 764, also tried it with 755.

    In all these cases, I am still receiving
    What should I do?
     
  2. Imai

    Imai Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    local delivery failed

    Hello Zeez
    Did you solve this problem?
    Please share
    Thank you
     
  3. MikeDVB

    MikeDVB Well-Known Member
    PartnerNOC

    Joined:
    Jun 4, 2008
    Messages:
    212
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Indiana, USA
    Is there anything in the error_log file in the same folder, how about the cPanel error log?
     
  4. Imai

    Imai Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Thank you Mike
    I solved this issue.

    It happens that I didn't have php handler defined in the filter.
    Its working now
     
  5. dHex

    dHex Registered

    Joined:
    Apr 10, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    @Mike, can you explain what you did a little bit more. I'm a n00b to this.
     
  6. Imai

    Imai Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    When adding the filter,

    1. Ensure you have the php handler defined if your script is a php file.

    This is what I have in the pipe to.
    |/usr/bin/php -q /full/path/to/myscript.php

    2. Make sure the script and the folder where it resides have permission 0755

    3. The script itself also has #!/usr/bin/php at the top before the php tag openening

    If you need further help, you can send me a private message

    Good Luck
    Imai
     
  7. dHex

    dHex Registered

    Joined:
    Apr 10, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Imai, thanks for your help.

    I was doing some trial and errors and i found out that my problem was with the file formatting. I'm working on windows xp machine and I'm using dreamwaver to edit my php and upload my pipe script using filezilla.

    The above procedure was creating some problem with the file formatting. Somewhere i read that any space between the hashbag and <?php will create problem.

    So what i did was to upload my pipe script to server without hashbag and let the server itself add it for me while setting up my email forward in cpanel. And if my script run into any error, now i use the code editor on cpanel's file manager. This was i managed to eliminate whatever makes the file incompatible for the server. my host is hostgator.

    I hope this may help someone.

    Demissew
     
  8. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
Loading...

Share This Page