The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem in setting subdomains with whm

Discussion in 'General Discussion' started by bsasninja, Feb 16, 2010.

  1. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    Im having a issue when setting subdomains at whm.

    I created through cpanel a subdomain called "webmail". The folder was created and inside of it I droped a index.html file.

    But when I call webmail.domain.com I get this

    Template Error: The template file must be given and is redirected to this url: http://webmail.domain.com/cgi-sys/defaultwebpage.cgi

    I set the template file as it said at whm, but when I type the subdomain in the address bar I get the template instead of the index.html I uploaded.

    What I´m doing wrong?? I´m using latest cpanel/whm release.

    Thanks
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    In WHM > Tweak Settings > Domains section check your settings:

    Something there might prove helpful to you. ;)
     
  3. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    What Infopro has detailed is correct; the applicable Tweak Setting option would need to be used to allow users to override the default proxy sub-domains. For additional reference information please also see the following related documentation resources (and specifically the "Domains" section of the Tweak Settings documentation):
    WHM: Main >> Server Configuration >> Tweak Settings >> Domains
     
Loading...

Share This Page