The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem in Update Server Software or other "yum" uses

Discussion in 'General Discussion' started by saqur, Sep 23, 2011.

  1. saqur

    saqur Member

    Joined:
    Oct 10, 2008
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hi There,

    I want to update my server software or system software in WHM. But I gave these errors:
    Code:
    Failed to download http://httpupdate.cpanel.net/RPM01/centos/5//pure-ftpd-1.0.32-1.tls..rpm.
    Failed to download http://httpupdate.cpanel.net/RPM01/centos/5//MySQL-server-5.1.56-0.glibc23..rpm.
    Failed to download http://httpupdate.cpanel.net/RPM01/centos/5//bandmin-1.6.1-4_newinit.noarch.rpm.
    Failed to download http://httpupdate.cpanel.net/RPM01/centos/5//dovecot-1.2.17-0cp..rpm.
    cPanel is not currently configured to use the nsd nameserver. Skipping scripts/nsdup
    Installing maildir version of exim
    Failed to download http://httpupdate.cpanel.net/RPM01/centos/5//exim-4.69-30_cpanel_maildir..rpm.
    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:
    
       libnssutil3.so: cannot open shared object file: No such file or directory
    
    Please install a package which provides this module, or
    verify that the module is installed correctly.
    
    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.4.3 (#1, Sep 21 2011, 20:06:00) 
    [GCC 4.1.2 20080704 (Red Hat 4.1.2-51)]
    
    If you cannot solve this problem yourself, please go to 
    the yum faq at:
      http://wiki.linux.duke.edu/YumFaq
    First problem is about downloading update packages.
    Second problem is about yum and python. I tried to do other uses of "yum" bat the same error happened.
    Please help me. what I must do?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Does /usr/lib have libnssutil3.so listed or any version of libnssutil in it?

    Code:
    ls -al /usr/lib/libnssutil*
    If not, you will need to find a copy of libnssutil3.so from a working machine or online for the OS version and architecture type you are using.
     
  3. saqur

    saqur Member

    Joined:
    Oct 10, 2008
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    No, it doesn't.
    My OS is CENTOS 5 i686 virtuozzo on server. I didn't find any file for my OS. This page has a version for most OSes but not for mine:
    http://pkgs.org/download/libnssutil3.so
    Can you help me find it?
     
  4. saqur

    saqur Member

    Joined:
    Oct 10, 2008
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    i386 will work for i686 systems as those are both 32-bit ones.
     
  6. saqur

    saqur Member

    Joined:
    Oct 10, 2008
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Thank you. :) It works.

    But my first problem still exist:
    Am I wrong about these packages & this is correct?
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Are you running /scripts/upcp --force or what is returning the error message indicated initially?
     
  8. saqur

    saqur Member

    Joined:
    Oct 10, 2008
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    When I try to upgrade MySQL version from 4.1.22 to 5.1 (Interactive upgrade) this is what happens:

    Code:
    [root@server ~]# /usr/local/cpanel/scripts/mysqlup --force
    Failed to download http://httpupdate.cpanel.net/RPM01/centos/5//MySQL-server-5.1.56-0.glibc23..rpm.
    Failed to install mysql51.
    
    I think something is wrong in file address. It should be like this:

    Code:
    http://httpupdate.cpanel.net/RPM01/centos/5/[B]i386[/B]/MySQL-server-5.1.56-0.glibc23.[B]i386[/B].rpm.
    
    Shouldn't?
     
    #8 saqur, Sep 23, 2011
    Last edited: Sep 23, 2011
  9. saqur

    saqur Member

    Joined:
    Oct 10, 2008
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Any Help?!
     
  10. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please open up a ticket, since I do not know now that yum is fixed why the files do not download. Any issues that cannot be resolved via the forums or are considered urgent would receive personalized assistance when opening up a free ticket with us for technical support. WHM > Support Center > Conact cPanel or using the link in my signature would be the two ways you could submit a ticket.
     
  11. saqur

    saqur Member

    Joined:
    Oct 10, 2008
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hi Tristan

    I did it yesterday and all issues are solved by cPanel technical support.

    Thank you for your helps.
     
Loading...

Share This Page