The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem in Update WHM

Discussion in 'General Discussion' started by Bulent Tekcan, Jan 11, 2006.

  1. Bulent Tekcan

    Bulent Tekcan Well-Known Member

    Joined:
    May 11, 2004
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Any idea for that problem ?


    (internal death) Thu Jan 12 00:28:35 2006 [4290] error: Modification of a read-only value attempted at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 279.
    eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 276
    require DBI.pm called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBD/mysql.pm line 7
    DBD::mysql::BEGIN() called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 0
    eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 0
    require DBD/mysql.pm called at /usr/local/cpanel/cpanellogd line 60
    main::BEGIN() called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 0
    eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 0
    [a fatal error or timeout occurred while processing this directive]==> cPanel Log Daemon version 22.2
    ==> Shared RRDTOOL support enabled
    ==> Starting cpbandwd (bandwidth monitoring for IMAP/POP)
    Can't locate File/Tail.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 . /usr/local/cpanel) at /usr/local/cpanel/bin/cpbandwd line 12.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cpbandwd line 12.
     
  2. katz_global

    katz_global Well-Known Member
    PartnerNOC

    Joined:
    Oct 18, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hosting from: Panama, Hong Kong, Singapore, Malays
    I am getting the same today. Can you access WHM? I am also getting a connection refused error in messages over ports 2087 and 2086.
     
  3. Secret Agent

    Secret Agent Guest

    What about /scripts/upcp --force OR cpanel update via WHM locking up at the "mysql update..." line?


    Anyone duplicating this? I did on release and current
     
  4. katz_global

    katz_global Well-Known Member
    PartnerNOC

    Joined:
    Oct 18, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hosting from: Panama, Hong Kong, Singapore, Malays
    all I have is ssh access right now. Someone here ran scripts/upcp --force and it never finished and then I did a killall -9 upcp yet the upcp command says its still running.

    I tried to reinstall cpanel but the wget http://layer1.cpanel.net/cpanel-universal-install.sea command just struggles at 1% for 5 minutes. Its like the cp server is down or jammed up.

    I have zero whm access still.
     
  5. katz_global

    katz_global Well-Known Member
    PartnerNOC

    Joined:
    Oct 18, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hosting from: Panama, Hong Kong, Singapore, Malays
    I think this is the problem

    http://forums.cpanel.net/showthread.php?t=48558

    Run /usr/local/cpanel/cpsrvd

    and you will probably get Cwd object version 3.14 does not match $Cwd::VERSION 3.11.

    You need to run scripts/upcp --force a few times I think to fix it. Something is wrong with the latest stable release update.
     
  6. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    @Bulent Tekcan

    Also you may need to update perl to 5.8.7 from layer1.cpanel.net and CPAN 1.83
    Looks like your OS update has downgraded perl to 5.0.8 which has been an issue lately.

    Do a search as this has been a very post intensive subject of late.

    :)
     
    #6 Izzee, Jan 11, 2006
    Last edited: Jan 11, 2006
Loading...

Share This Page