Problem Instalilng aide checking for mhash_get_block_size in -lmhash... no

AbeFroman

BANNED
Feb 16, 2002
644
1
318
checking for mhash_get_block_size in -lmhash... no
configure: error: You must have libmhash properly installed.

i have mhash installed and made sure my path to mhash.so was in /etc/ld.so.conf

Why am I getting that error?
 

carluk

Well-Known Member
Sep 2, 2003
161
0
166
What application are you installing and how are you installing it?
 

dgbaker

Well-Known Member
PartnerNOC
Sep 20, 2002
2,531
9
343
Toronto, Ontario Canada
cPanel Access Level
DataCenter Provider
To get AIDE to install properly do the following;

For mhash
Code:
cd /home/cpapachebuild/buildapache/mhash-0.8.18
make clean
./configure --enable-static
make
make install
Now you can install AIDE
Code:
./configure
more INSTALL
make
make check
make install
Notice that for AIDE I did not use the --enable-static=yes option and did a standard configure.
 

AbeFroman

BANNED
Feb 16, 2002
644
1
318
Hi,

Thanks, but it gives me the same error:
checking for mhash_get_block_size in -lmhash... no
configure: error: You must have libmhash properly installed.

I tried with and without --enable-static=yes option.
 

d-woo

Well-Known Member
Aug 9, 2003
88
0
156
dgbaker said:
To get AIDE to install properly do the following;

For mhash
Code:
cd /home/cpapachebuild/buildapache/mhash-0.8.18
make clean
./configure --enable-static
make
make install
Hi dg,

I recently recompiled Apache with mhash added.

Here is what I have:

Code:
/home/cpapachebuild/buildapache/mhash-0.8.18.tar.gz
/home/cpphpbuild/php-4.3.9/ext/mhash
/home/cpphpbuild/php-4.3.9/ext/mhash/tests
/home/cpphpbuild/php-4.3.9/ext/mhash/tests/skip.inc
/home/cpphpbuild/php-4.3.9/ext/mhash/tests/001.phpt
/home/cpphpbuild/php-4.3.9/ext/mhash/tests/002.phpt
/home/cpphpbuild/php-4.3.9/ext/mhash/tests/003.phpt
/home/cpphpbuild/php-4.3.9/ext/mhash/config.m4
/home/cpphpbuild/php-4.3.9/ext/mhash/mhash.c
/home/cpphpbuild/php-4.3.9/ext/mhash/php_mhash.h
/home/cpphpbuild/php-4.3.9/ext/mhash/CREDITS
/home/cpphpbuild/php-4.3.9/ext/mhash/mhash.dsp
Do I need to untar the mhash-0.8.18.tar.gz?

I do not have /home/cpapachebuild/buildapache/mhash-0.8.18
 

ttremain

Well-Known Member
Feb 16, 2003
246
2
168
cPanel Access Level
Root Administrator
dgbaker said:
To get AIDE to install properly do the following;

For mhash
Code:
cd /home/cpapachebuild/buildapache/mhash-0.8.18
make clean
./configure --enable-static
make
make install
Now you can install AIDE
Code:
./configure
more INSTALL
make
make check
make install
Notice that for AIDE I did not use the --enable-static=yes option and did a standard configure.
I have done this, on multiple servers, but When I get to the aide install, and ./configure I always get:

checking for mhash_get_block_size in -lmhash... no
configure: error: You must have libmhash properly installed.

I've tried this on two servers, one is redhat 9, the other is Centos 3.4. I fear to try it on any others.