The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem Instalilng aide checking for mhash_get_block_size in -lmhash... no

Discussion in 'General Discussion' started by AbeFroman, Sep 21, 2004.

  1. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    checking for mhash_get_block_size in -lmhash... no
    configure: error: You must have libmhash properly installed.

    i have mhash installed and made sure my path to mhash.so was in /etc/ld.so.conf

    Why am I getting that error?
     
  2. carluk

    carluk Well-Known Member

    Joined:
    Sep 2, 2003
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    16
    What application are you installing and how are you installing it?
     
  3. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
  4. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    bump......
     
  5. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    To get AIDE to install properly do the following;

    For mhash
    Code:
    cd /home/cpapachebuild/buildapache/mhash-0.8.18
    make clean
    ./configure --enable-static
    make
    make install
    
    Now you can install AIDE
    Code:
    ./configure
    more INSTALL
    make
    make check
    make install
    
    Notice that for AIDE I did not use the --enable-static=yes option and did a standard configure.
     
  6. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    Hi,

    Thanks, but it gives me the same error:
    checking for mhash_get_block_size in -lmhash... no
    configure: error: You must have libmhash properly installed.

    I tried with and without --enable-static=yes option.
     
  7. d-woo

    d-woo Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
     
  8. ttremain

    ttremain Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    16
    I have done this, on multiple servers, but When I get to the aide install, and ./configure I always get:

    checking for mhash_get_block_size in -lmhash... no
    configure: error: You must have libmhash properly installed.

    I've tried this on two servers, one is redhat 9, the other is Centos 3.4. I fear to try it on any others.
     
Loading...

Share This Page