Problem receiving emails after updating cPanel

cmonego

Member
Jul 10, 2014
21
1
3
cPanel Access Level
Root Administrator
Hello,

After updating WHM / cPanel from Version 11.50.0.29 to version 11.54.0.36 my server stopped receiving emails from recipients like Google, Outlook and Yahoo. Everything was working before the update, but now, there are not even logs of attempts to deliver these emails on the server.

What might have caused this problem?

[]'s
 

cmonego

Member
Jul 10, 2014
21
1
3
cPanel Access Level
Root Administrator
Hello,

I disabled the "Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam." and I received the emails again.
 

CHWSUK

Registered
Feb 16, 2017
3
0
1
Larne
cPanel Access Level
Root Administrator
I can confirm, inbound emails from BT Internet, Gmail, Yahoo, etc were being blocked inbound AND emails sent to those addresses from WebMail as an update to this post were also getting bounced, so inbound and outbound.

Disabling: "Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam." worked.

Note however, WHY was this turned on without notifying? As this is a bit of a email breaker config option.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Hello,

The Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam option was implemented in cPanel version 11.52:

11.52 Release Notes - 11.52 Documentation - cPanel Documentation

I've not seen any additional reports regarding this feature blocking email from legitimate mail service providers such as Google or Outlook, but we are happy to take a closer look if you'd like to open a support ticket. As far as SMTP delivery, it's possible that relates to the change in POP before SMTP functionality in 11.52:

Antirelayd renamed to popbeforesmtp

Keep in mind the version of cPanel you updated your system to (cPanel 54) is already at EOL status:

cPanel & WHM Version 54 Now EOL, Cent 5 & Cent 6-32bit in 3 Months | cPanel Newsroom

I recommend updating to a supported version of cPanel at your earliest convenience to see if any issues persist.

Thank you.
 

CHWSUK

Registered
Feb 16, 2017
3
0
1
Larne
cPanel Access Level
Root Administrator
Hi,

Where i understand this was the case, the fact I was running cPanel & WHM 64.0 (build 15) then updated to Build 17, this broke right after the update to build 17 as either i did not realise it was enabled or the build 17 has an issue with it. I'm not the only person to see this.

Kind Regards.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Where i understand this was the case, the fact I was running cPanel & WHM 64.0 (build 15) then updated to Build 17, this broke right after the update to build 17 as either i did not realise it was enabled or the build 17 has an issue with it. I'm not the only person to see this.
Hello,

I'm not seeing additional reports regarding this feature blocking email from providers such as Gmail. Could you open a support ticket using the link in my signature so we can take a closer look at the affected system and see what's happening?

Thank you.
 

htmldesign

Member
Oct 29, 2015
9
0
1
Canada
cPanel Access Level
Root Administrator
Hello,

I'm not seeing additional reports regarding this feature blocking email from providers such as Gmail. Could you open a support ticket using the link in my signature so we can take a closer look at the affected system and see what's happening?

Thank you.

Hi @cPanelMichael , @CHWSUK , @cmonego ;

We are having the same issue. Everything (incoming emails ) was working fine before updating
to 64 build 21.
We have had over 80 tickets in the last 24 hours. It's intermittent, which makes it hard to troubleshoot.

Please, could someone enlighten us on how can we fix this ? The issue is precisely the same as described
by cmonego on the initial thread.

Thanks in advance for your help,
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Hello @htmldesign,

Could you open a support ticket using the link in my signature if this is still happening so we can take a closer look? You can post the ticket number here and we will update this thread with the outcome.

Thank you.
 
Thread starter Similar threads Forum Replies Date
A Email 2
A Email 1
X Email 2
C Email 2
A Email 1