The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem receiving emails

Discussion in 'E-mail Discussions' started by sean2045, Jul 9, 2012.

  1. sean2045

    sean2045 Member

    Joined:
    Jul 1, 2012
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I tried to fix incoming email problems for a few hours, I couldn't find a solution and couldn't found any errors in log file.

    send email from support@website.com using webmail to my yahoo email has no problem.
    send or reply email from my yahoo email or gmail email to support@website.com, the email just disappeared with no errors report to exim_mainlog or maillog

    maillog details:
    Jul 9 13:20:23 wii dovecot: imap-login: Login: user=<support@website.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Jul 9 13:20:23 wii dovecot: IMAP(support@website.com): Disconnected: Logged out bytes=57/417
    Jul 9 13:20:24 wii dovecot: imap-login: Login: user=<support@website.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Jul 9 13:20:24 wii dovecot: IMAP(support@website.com): Disconnected: Logged out bytes=50/410

    exim_mainlog:
    no errors:
    2012-07-09 13:23:22 cwd=/etc/csf 2 args: /usr/sbin/exim -bpc
    2012-07-09 13:25:02 cwd=/ 2 args: /usr/sbin/exim -bpu

    I double checked in WHM Mailserver Selection and Mailserver Configuration, all default setting. chose Automatically Detect Configuration for mx entry.

    I'm kind of lost here, anything else do i need to check?

    Thanks

    sean
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Sean,

    So are you even seeing the email coming in from yahoo to that email account in exim_mainlog?

    Code:
    exigrep email@yahoo.com /var/log/exim_mainlog
    Please replace email@yahoo.com with your yahoo email account.

    Thanks!
     
  3. sean2045

    sean2045 Member

    Joined:
    Jul 1, 2012
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator

    Thank you for reply, I have tried to solve the problem since 2 days ago, and I received the bounce email from yahoo.com it says no no mx or a records, i also tried on my other emails and all failed. However, I double checked my domain name at MX Lookup Tool - Check your DNS MX Records online - MxToolbox, MX and A record looks fine.

    I trid both webmail and windows live mail, can't receive any email either.

    I tried this exigrep email@yahoo.com /var/log/exim_mainlog after I send email to my gmail.com and replied.

    Code:
    2012-07-11 11:11:26 1SoyZa-0001VQ-07 <= support@mydomain.com H=c-76-24-169-65.hsd1.ma.comcast.net (seanPC) [76.24.169.65]:52904 P=esmtpa A=dovecot_login:support@mydomain.com S=1245 id=5F8ECABB57AD40C793BDD74A4B9127FB@seanPC T="emal problems" for seanuser@gmail.com
    2012-07-11 11:11:26 1SoyZa-0001VQ-07 SMTP connection outbound 1342019486 1SoyZa-0001VQ-07 email.com seanuser@gmail.com
    2012-07-11 11:11:47 1SoyZa-0001VQ-07 gmail-smtp-in-v4v6.l.google.com [2001:4860:b007::1a] Connection timed out
    2012-07-11 11:11:49 1SoyZa-0001VQ-07 => seanuser@gmail.com R=dkim_lookuphost T=dkim_remote_smtp H=gmail-smtp-in-v4v6.l.google.com [209.85.225.27] X=TLSv1:RC4-SHA:128
    2012-07-11 11:11:49 1SoyZa-0001VQ-07 Completed
    
    what was the problem?

    Thanks

    Sean
     
  4. nwtg

    nwtg Active Member

    Joined:
    Dec 24, 2010
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Portland, Oregon
    cPanel Access Level:
    Root Administrator
    See if anything's being reported in /var/log/exim_rejectlog or exim_faillog. Also go to intoDNS: checks DNS and mail servers health and run a check on your domain, make sure that the MX records can be resolved externally. Also go into that domain's cpanel account, and try disable/enable of both SPF and DKIM. Could be something in the DNS zone for that domain, too. Is this a standalone DNS config or are you clustered?
     
  5. sean2045

    sean2045 Member

    Joined:
    Jul 1, 2012
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    this is how i did:

    I Disabled SPF and DKIM on my domain name and rebooted the VPS.

    login SSH, I cleared exim_mainlog, exim_paniclog, exim_rejectlog, maillog

    I used windows live mail sent a email to my gmail.com, and after I received, and i replied.

    exim_mainlog:
    Code:
    2012-07-11 11:57:48 SMTP connection from [76.24.169.65]:53534 (TCP/IP connection count = 1)
    2012-07-11 11:57:49 1SozIT-0000b2-Ff <= support@yourdomain.com H=c-76-24-169-65.hsd1.ma.comcast.net (seanPC) [76.24.169.65]:53534 P=esmtpa A=dovecot_login:support@yourdomain.com S=1311$
    2012-07-11 11:57:49 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1SozIT-0000b2-Ff
    2012-07-11 11:57:49 1SozIT-0000b2-Ff SMTP connection outbound 1342022269 1SozIT-0000b2-Ff yourdomain.com seanuser@gmail.com
    2012-07-11 11:57:49 SMTP connection from c-76-24-169-65.hsd1.ma.comcast.net (seanPC) [76.24.169.65]:53534 closed by QUIT
    2012-07-11 11:58:10 1SozIT-0000b2-Ff gmail-smtp-in-v4v6.l.google.com [2001:4860:b007::1b] Connection timed out
    2012-07-11 11:58:12 1SozIT-0000b2-Ff => sean2045@gmail.com R=lookuphost T=remote_smtp H=gmail-smtp-in-v4v6.l.google.com [209.85.225.26] X=TLSv1:RC4-SHA:128
    2012-07-11 11:58:12 1SozIT-0000b2-Ff Completed
    2012-07-11 11:59:01 cwd=/etc/csf 2 args: /usr/sbin/exim -bpc
    2012-07-11 11:59:05 SMTP connection from [127.0.0.1]:48022 (TCP/IP connection count = 1)
    2012-07-11 11:59:07 SMTP connection from localhost [127.0.0.1]:48022 closed by QUIT
    2012-07-11 12:00:02 cwd=/ 2 args: /usr/sbin/exim -bpu
    
    maillog:
    Code:
    Jul 11 11:58:51 wii dovecot: pop3-login: Login: user=<support@yourdomain.com>, method=PLAIN, rip=76.24.169.65, lip=23.29.123.137
    Jul 11 11:58:51 wii dovecot: POP3(support@yourdomain.com): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0, bytes=12/43
    Jul 11 11:58:53 wii dovecot: pop3-login: Login: user=<support@yourdomain.com>, method=PLAIN, rip=76.24.169.65, lip=23.29.123.137
    Jul 11 11:58:53 wii dovecot: POP3(support@yourdomain.com): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0, bytes=12/43
    Jul 11 11:58:54 wii dovecot: pop3-login: Login: user=<support@yourdomain.com>, method=PLAIN, rip=76.24.169.65, lip=23.29.123.137
    Jul 11 11:58:54 wii dovecot: POP3(support@yourdomain.com): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0, bytes=12/43
    Jul 11 11:58:55 wii dovecot: pop3-login: Login: user=<support@yourdomain.com>, method=PLAIN, rip=76.24.169.65, lip=23.29.123.137
    Jul 11 11:58:56 wii dovecot: POP3(support@yourdomain.com): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0, bytes=12/43
    Jul 11 11:58:57 wii dovecot: pop3-login: Login: user=<support@yourdomain.com>, method=PLAIN, rip=76.24.169.65, lip=23.29.123.137
    Jul 11 11:58:57 wii dovecot: POP3(support@yourdomain.com): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0, bytes=12/43
    Jul 11 11:59:04 wii dovecot: imap-login: Login: user=<__cpanel__service__auth__imap__q_ipjcyrlvlgqy8w0ziiwrg5ff0gawhqyw8o4adlg7gq6l...>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1$
    Jul 11 11:59:04 wii dovecot: IMAP(__cpanel__service__auth__imap__q_ipjcyrlvlgqy8w0ziiwrg5ff0gawhqyw8o4adlg7gq6lbk3wvcdaysa7akcbju): Disconnected: Logged out bytes=11/340
    Jul 11 11:59:16 wii dovecot: pop3-login: Login: user=<support@yourdomain.com>, method=PLAIN, rip=76.24.169.65, lip=23.29.123.137
    Jul 11 11:59:16 wii dovecot: POP3(support@yourdomain.com): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0, bytes=12/43
    Jul 11 11:59:18 wii dovecot: pop3-login: Login: user=<support@yourdomain.com>, method=PLAIN, rip=76.24.169.65, lip=23.29.123.137
    Jul 11 11:59:18 wii dovecot: POP3(support@yourdomain.com): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0, bytes=12/43
    
    Exim_paniclog and exim rejectlog are empty, nothing in it.

    I checked my domain name on intodns.com, everything looks fine.

    I'm totally lost, could be something wrong with my VPS provider or the datecenter? could someone help me with this problem and login in my VPS check what is wrong? I'll send a PM about my VPS login info.

    Thanks

    Sean
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hi Sean,

    Are you only using IPv6? I ask as this is the connection timed out portion of the exim_mainlog entry:

    Notice how it hows an IPv6 IP rather than an IPv4 one? What do you have in /etc/hosts file? What about /etc/resolv.conf file?

    Thanks!
     
  7. sean2045

    sean2045 Member

    Joined:
    Jul 1, 2012
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator

    this is /etc/hosts

    ::1 localhost localhost.localdomain localhost6 localhost6.localdoma$
    127.0.0.1 localhost.localdomain localhost localhost4.localdomain4 localhost4
    # Auto-generated hostname. Please do not remove this comment.
    23.29.xxx.xxx vps.mydomain.com vps

    this is /etc/resolv

    nameserver 8.8.8.8
    nameserver 8.8.4.4
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Could you go ahead and open up a ticket? I'm not certain why the message appears to be showing the wrong connection IP for email. We'll need to look over your exim configurations and your ifconfig details on the machine.

    Tickets can be opened using WHM > Support Center > Contact cPanel or using the link in my signature.

    Thanks!
     
  9. sean2045

    sean2045 Member

    Joined:
    Jul 1, 2012
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you.

    I opened a ticket(Request Id: 2908530) a few hours ago, still waiting for answer and I provided all info that I have.


    this ip 76.24.169.65 is my home ip address which I used windows live mail on my computer( not sure if you're talking about this ip).


    Sean
     
Loading...

Share This Page