Problem restoring account-Provide the “target_blocks_free” parameter for the Cpanel::DiskCheck

petrogazz

Registered
Dec 3, 2014
3
0
1
cPanel Access Level
Root Administrator
Hello all,

on an newly installed openvz VPS 11.54.0.18 we encountered the followind issue when trying to restore accounts via transfer tool or command line:

Code:
Provide the “target_blocks_free” parameter for the “Cpanel::DiskCheck::target_on_host_has_enough_free_space_to_fit_source_sizes” function.
VPS is running fine, there is enough diskspace.

Could it be something on cpanel configuration or should we look in the openvz settings.

Thanking you in advance!
 

petrogazz

Registered
Dec 3, 2014
3
0
1
cPanel Access Level
Root Administrator
New server node with ovzkernel 2.6.32-042stab113.11
Container CTID.conf has the following attributes
QUOTATIME="0"
QUOTAUGIDLIMIT="1000"
DISK_QUOTA=yes
VE_LAYOUT="simfs"
Which logs would be helpful?
The problem must be on the server node because I installed an new VPS and I get the same error.

Thanks for your time
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

To update, it looks like the issue was addressed via a support ticket. A couple of symbolic links for aquota.user and aquota.group were removed and regenerated. Upon performing that action and rebuilding quotas, the account restore completed successfully.

Thank you.
 

petrogazz

Registered
Dec 3, 2014
3
0
1
cPanel Access Level
Root Administrator
Figured it out.

It was an openvz kernel bug on the latest stable release 2.6.32-042stab113.11, installed the testing kernel 2.6.32-042stab113.12 and quota is ok now.

[OVZ-6661] `quota` is not working on latest kernel if running command not from / on simfs - bugs.openvz.org

The solution the support team gave us in the ticket was right, but second level quotas were still broken.

Running /scripts/fixquotas --force was giving error
edquota: Cannot stat() mounted device simfs: No such file or directory

After installing the testing kernel I was able to run the script without errors and second level quotas were successfully enabled.

Thank you for your help!

;)
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
I am happy to see the issue is now resolved. Thank you for updating us with the outcome.