The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem sending to Cox.net

Discussion in 'General Discussion' started by TomB, Dec 27, 2006.

  1. TomB

    TomB Member

    Joined:
    Sep 3, 2002
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    The problem started a couple of months ago. First I had reports from customers, not receiving mail sent from cox.net. I was able to get that working by going to, Service Configuration > Exim Configuration Editor > and checking the "Use callouts to verify the existence of email senders". Now, I'am getting reports that customers using my server for smtp can't send to cox.net customers. Has anyone else experienced this? Cox, I might add is of no help in resolving this. Thanks in advance for any insights you might provide.
     
  2. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    I've been with cox about 10 years now. Here's some of my observations:

    1) They implemented blocking both ports 25 and 26 quite a while ago. Luckily, I run my own servers so I simply set up Exim to run on port 27. :D

    2) They have intermittant periods where the email is delayed. I've seen it very from an hour to a few days. It seems to always get delivered but there are times it's delayed for unknown reasons.

    3) Probably in the last 3 or 4 months, I noticed that they started using some blacklists. Notedly, surbl. If you have a URL in the email that is listed in the surbl then it will be rejected. This can be in the signature line also.

    To determine why it's being blocked, you need review your mail logs to see why it's being rejected. I try to get customers to forward a bounce to me. If rejected because of the surbl, it's being scanned before the message is accepted and will be rejected immediately. Clients may get a popup stating it was rejected.
     
  3. TomB

    TomB Member

    Joined:
    Sep 3, 2002
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply. I too, have configured Exim to use port 27 and can send mail using my server while connected to the cox network. However, I use the cox smtp server most of the time. My server nor the IP is listed on any SURBL list. I've tested with Spamassassin both enabled and disabled. The funny thing is I'm not getting any reject or returns on mail sent to cox.net .. the mail is just not getting through. Thanks for your input.
     
  4. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Do you have SPF for the domains and reverse DNS setup on your mail server IP?
     
  5. TomB

    TomB Member

    Joined:
    Sep 3, 2002
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Reverse DNS is set up. SPF is not
     
  6. markfrompf

    markfrompf Well-Known Member

    Joined:
    Mar 27, 2006
    Messages:
    176
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Los Angeles, CA
  7. TomB

    TomB Member

    Joined:
    Sep 3, 2002
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Mark. Let me ask you this. Since there is one reseller on the server besides myself I have the server set up with "mydomain.com" as one reseller (me) and "myreseller.com" set up as another. mydomain.com uses the primary IP and myreseller has a dedicated IP. Now the question is do I need to set the SPF up for me AND myreseller? And do ALL the domains being hosted on the server either by me or my reseller ALSO need to have SPF added to their individual zone files? Thanks again for your help.
     
  8. TomB

    TomB Member

    Joined:
    Sep 3, 2002
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Adding the SPF sorted it out! Thanks to everyone for all the help.
     
Loading...

Share This Page