The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem setting up RBLs in Exim

Discussion in 'General Discussion' started by jrehmer, May 3, 2007.

  1. jrehmer

    jrehmer Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Denver, CO
    Hello,

    I'm trying to follow a widely used/implemented instruction set on setting up RBLs within the exim config, but apparently the newer version of exim has a slightly different exim.conf file. Specifically I am speaking about the statement "Scroll down the center window of the ACL section, directly below the line:
    accept domains = +local_domains"

    I don't have any other "accept domains = +local_domains" in my config besides the one that the guide has you put in the first step.

    I'm running the latest edge (11.3) which I'm sure has something to do with it, but I'd like clarification on how this should be modified to work with the current version.

    Here is (a portion of) the document that I am referencing:


    -------------------------------
    EXIM CONFIGURATION EDITOR
    -------------------------------

    If you use the WHM-based Exim Configuration Editor, all of your modifications will be reproduced after each update. If you edit exim.conf directly, cPanel updates MAY overwrite your changes! Because of this, the following changes should be entered using the Exim Configuration Editor.

    ------------------------
    Setting up lsearch files
    *******************

    At the top of the editor, in the window below:
    #!!# cPanel Exim 4 Config

    Enter these lines:
    domainlist rbl_blacklist = lsearch;/etc/rblblacklist
    domainlist rbl_bypass = lsearch;/etc/rblbypass
    hostlist rbl_whitelist = lsearch;/etc/relayhosts : partial-lsearch;/etc/rblwhitelist

    ----------------------------
    RBL entries in ACL Section
    *********************

    RBL selection depends on many factors, be sure to edit the list below to reflect your priorities... Postmaster and abuse bypass allows blocked users to contact admin.

    In the center window of the ACL section, directly below the line:
    accept hosts = :

    Enter these lines:
    #**#
    #**# RBL List Begin
    #**#
    #
    # Always accept mail to postmaster & abuse for any local domain
    #
    accept domains = +local_domains
    local_parts = postmaster:abuse
    #
    # Check sending hosts against DNS black lists.
    # Accept all locally generated messages
    # Reject message if address listed in blacklist.
    deny message = Message rejected because $sender_fullhost \
    is blacklisted at $dnslist_domain see $dnslist_text
    !hosts = +relay_hosts
    !authenticated = *
    dnslists = dnsbl.njabl.org : \
    bl.spamcop.net : \
    sbl.spamhaus.org : \
    list.dsbl.org : \
    cbl.abuseat.org : \
    relays.ordb.org
    # RBL Bypass Local Domain List
    !domains = +rbl_bypass
    # RBL Whitelist incoming hosts
    !hosts = +rbl_whitelist
    #**#
    #**# RBL List End
    #**#

    Scroll down the center window of the ACL section, directly below the line:
    accept domains = +local_domains
    Enter these lines:
    #**#
    #**# Reject Email to Invalid Recipient
    #**#
    endpass
    message = unknown user
    verify = recipient
    #**#


    --------------------------------
    RBL entries in ROUTERS Section
    **************************

    In the ROUTERS section window, directly below the line:
    # in the "local_domains" setting above.

    Enter these lines:
    # Deny and send notice to list of rejected domains.
    reject_domains:
    driver = redirect
    # RBL Blacklist incoming hosts
    domains = +rbl_blacklist
    allow_fail
    data = :fail: Connection rejected: SPAM source $domain is manually blacklisted.
     
  2. Bruce

    Bruce Well-Known Member

    Joined:
    Oct 4, 2001
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    We have the same problem. Just updated one of the servers to the newer Exim in cpanel 11.

    Does anyone know were to put this:

    # RBL Bypass Local Domain List
    !domains = +rbl_bypass
    # RBL Whitelist incoming hosts
    !hosts = +rbl_whitelist
    #**#
    #**# RBL List End

    We have some clients that do not want any spam filtering but most do.
    I would hate to go back to the old ver again.
     
  3. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    Same problem here accept domains = +local_domains doesnt exists.

    Anyone has solved this?
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,451
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    This one I take it? http://www.webhostgear.com/175_print.html

    I think there are more than a few articles on his site (great help site with lots of good info on it all the same) that are outdated. At that link above it states,

    So, that particular article is at least several years old, and outdated for cPanel11 I would think.


    I think it's safe to say that this route, http://www.configserver.com/cp/mailscanner.html is more widely used/implemented these days. And covers this area quite well.

    Also if you use the mailscanner front end, http://www.configserver.com/cp/msfe.html you can enable / disable scanning per domain all from within WHM. (and set to allow auser to choose for themselves if they want mail scanned or not too!)

    I guess some might like to wrap thier heads around all this and understand it completely. Great idea. Others like myself, would rather trust the pros to develop and maintain what works well and use that.

    FAQ about this MS service he offers. http://www.configserver.com/sfaq/faqlist.php?catid=3 might help you a bit.

    In other words, you can take an easy route or the tougher route, IMHO. cPanel11 has made some significant changes in this area and many of the options on that outdated article have been added to exim, you see them when you go to config editor, at top of page before the Advanced editor button.

    At any rate, that's just my 2 cents. YMMV.
     
  5. getinlucky2

    getinlucky2 Registered

    Joined:
    Aug 4, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Tampa, FL
    Enable RBLs in Exim

    Using cPanel Version 11.10.0-RELEASE

    RBL can be turned on at Main : Service Configuration : Exim Config. Editor - under "Standard Options - ACLS"

    Just check the boxes according to what RBL services you would like.

    Hope this helps.
     
  6. bosen

    bosen Member

    Joined:
    Apr 12, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
Loading...

Share This Page