The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem starting SSHD

Discussion in 'General Discussion' started by autolux, Mar 20, 2010.

  1. autolux

    autolux Member

    Mar 11, 2010
    Likes Received:
    Trophy Points:

    running cPanel/WHM on Centos 5.4 VPS and having no luck getting sshd to start.

    i get the following error every time:

    cp: cannot create regular file `/var/empty/sshd/etc': No Such file or directory
    Starting sshd: Missing privilege separation directory: /var/empty/sshd

    now obviously you'd think this is to do with directory permissions.. i've tried chmod, chown, rmdir, mkdir etc. on the /var/empty/sshd directory nothing is allowed to touch it - returns error /var/empty/sshd: no such file or directory.

    i cannot uninstal reinstall either.

    when doing 'll' on the /var/empty folder, sshd appears as follows:

    ?--------- ? ? ? ? ? sshd

    the sshd is highlighted in red.

    i can make files in this directory and other things, just wont let you touch the sshd folder, apply permissions etc.

    the sshd user and group exists and ive tried messing about with them but nothing lets you touch this folder.

    if i change the sshd_config for useprivilegeseparation from yes no, then i can start sshd, but then i believe this is quite insecure.

    any advice please?
  2. WiredTree Joe

    WiredTree Joe Well-Known Member

    Dec 13, 2006
    Likes Received:
    Trophy Points:
    Chicago, IL
    Is your VPS Virtuozzo based? If so, a directory or file that is showing ?--------- ? ? ? ? ? for the permissions and red most likely means your VZ template is missing or corrupted. I would contact your VPS provider to have that addressed.

Share This Page