SOLVED problem STMP remote connection refused

adilos

Registered
Dec 8, 2020
3
0
1
Morocco
cPanel Access Level
Root Administrator
Hi i have problem with stmp remote connection it was working until i reinstalled whm

and now is not working here my php script im using to connet


$mail = new PHPMailer;

//$mail->SMTPDebug = 2; // Enable verbose debug output

$mail->isSMTP(); // Set mailer to use SMTP
$mail->Host = 'cpanel.xxxxxx.com'; // Specify main and backup SMTP servers
$mail->SMTPAuth = true; // Enable SMTP authentication
$mail->Username = '[email protected]'; // SMTP username
$mail->Password = 'xxxxxxxxx'; // SMTP password
$mail->SMTPSecure = 'tls'; // Enable TLS encryption, `ssl` also accepted
$mail->Port = 587; // TCP port to connect to

$mail->From = '[email protected]';
$mail->FromName = 'MyServer';
$mail->addAddress($line["phone"]); // Name is optional
$mail->isHTML(true); // Set email format to HTML
$mail->Subject = 'Your Account ('.$line["name"].') Has Been Extended';
$mail->Body = 'Dear '.$line["displayname"].','. "<br>". "<br>".

and here is message error on /var/log/exim_mainlog

2020-12-08 07:50:55 SMTP connection from [51.xx.x.xxx]:35332 (TCP/IP connection count = 1)
2020-12-08 07:50:55 TLS error on connection from (s1.xxxxx.com) [51.xx.x.xxx]:35332 (SSL_accept): error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol
2020-12-08 07:50:55 SMTP connection from (s1.xxxxx.com) [51.xx.x.xxx]:35332 closed by EOF
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,874
907
313
cPanel Access Level
Root Administrator
Hey there! Is it possible the reinstall of WHM also updated your cPanel version? Could you check this thread, which in turn has links to other threads with PHP connection issues, to see if these help you out?

 
  • Like
Reactions: adilos

adilos

Registered
Dec 8, 2020
3
0
1
Morocco
cPanel Access Level
Root Administrator
Hey there! Is it possible the reinstall of WHM also updated your cPanel version? Could you check this thread, which in turn has links to other threads with PHP connection issues, to see if these help you out?

Thank you problem resolved :cool: