The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem terminate a account

Discussion in 'General Discussion' started by snaaps, Dec 14, 2004.

  1. snaaps

    snaaps Member

    Joined:
    Oct 8, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    When I terminate an account in WHM my cpu load goes up to 13.0
    When I go to CPU/Memory/MySQL Usage I See the following:

    Top Process %CPU 76.0 /usr/sbin/grpck
    Top Process %CPU 75.9 /usr/sbin/grpck
    Top Process %CPU 75.8 /usr/sbin/grpck
    dkplace dkplace.net 0.62 2.26 0.0
    Top Process %CPU 1.5 [cpanel-email]
    Top Process %CPU 0.6 proftpd: dkplace - 80.60.38.121: IDLE
    Top Process %CPU 0.4 proftpd: dkplace - 80.60.38.121: IDLE


    Everytime I terminate an account I will see usr/sbin/grpck eating my cpu!
    The CPU is after 30 a 60 minutes back to normal and the account is still there on my server!

    Has anyone a solution?
     
  2. snaaps

    snaaps Member

    Joined:
    Oct 8, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I tried everithink!
    But the problem is still there!
    Are there more people that haves this problem with terminate an account?

    Please somebody help me!!!!
     
    #2 snaaps, Dec 15, 2004
    Last edited: Dec 15, 2004
  3. groefie

    groefie Active Member

    Joined:
    May 30, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    The same problem here! CPU load is going crazy (above 20) when terminating an account. The account isn't on the server anymore after that, but the username still exists. I tried to install a backup of a site but cpanel says 'username already taken' even the account isn't on the server anymore.

    I'm using WHM 9.9.9 cPanel 9.9.9-R14
    Fedora i686 - WHM X v3.1.0

    Tried to downgrade to the latest release version, but that didn't work :(
     
  4. snaaps

    snaaps Member

    Joined:
    Oct 8, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I have delete the username in shh.
    thats works then you can create the account again.

    But still my server load is up to 18 when I delete a account in whm.

    what for processes generated high cpu load by you?
     
  5. groefie

    groefie Active Member

    Joined:
    May 30, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    14492 root 0 10.4 4.5 /usr/sbin/grpck
    1970 nobody 0 6.2 2.6 /usr/local/apache/bin/httpd -DSSL
    2007 nobody 0 5.8 2.6 /usr/local/apache/bin/httpd -DSSL
    2022 nobody 0 5.8 2.5 /usr/local/apache/bin/httpd -DSSL
    1992 mailnull 0 3.9 0.7 /usr/sbin/exim -bd -q60m
    2027 nobody 0 3.9 2.3 /usr/local/apache/bin/httpd -DSSL
    1973 nobody 0 3.6 2.6 /usr/local/apache/bin/httpd -DSSL
    2005 nobody 0 2.3 2.4 /usr/local/apache/bin/httpd -DSSL


    SSH is broken on that server, so this is the output of the current cpu usage in WHM
     
    #5 groefie, Dec 16, 2004
    Last edited: Dec 16, 2004
  6. hostcp3

    hostcp3 Well-Known Member

    Joined:
    Jun 18, 2002
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    Same here on our new server.

    do me a favor guys and post

    OS and check your /etc/gshadow files please for corruption.

    Cpanel support ticket on this: 83219

    Just to help a bit as we have had this issue for a few days.

    Kill grpck from command line
    run command: userdel username
    remove /home/username
    edit /etc/group and /etc/passwd to ensure user has been removed

    check /etc/gshadow for corruption
    check httpd.conf to ensure users entry has been removed.

    If your /etc/gshadow is corrupted run: grpconv
    to create a new /etc/gshadow file.

    copy that new file to /etc/gshadow.good and use that to restore each time you remove an account and edit it manually to remove user.
     
    #6 hostcp3, Dec 18, 2004
    Last edited: Dec 18, 2004
  7. hostcp3

    hostcp3 Well-Known Member

    Joined:
    Jun 18, 2002
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16

    You might fine that user_mod is also locked on, find that process and kill.
     
  8. aqua

    aqua Member

    Joined:
    Nov 17, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    This is exactly what's going on with my server too in the previous thread.Still haven't fixed it totally,figured how to delete the username's but the account wont delete,server starts the countdown from 100 secs then crashes and reboots. :confused:
     
  9. aqua

    aqua Member

    Joined:
    Nov 17, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Fixed it.
    I had to suspend all accounts to keep the CPU down.
    Then attempted to remove the problem account but it said username already exist so i then went into the ect/passwd and deleted the username and tried to recreate the account again but still no joy as the username still already exists.Warning info at the top of the WHM panel on these account creation pages then told me to delete the user from ect/groups i did that and it all worked fine...Hope this helps ;)
     
  10. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    This is caused by a bug in Fedora's shadow-utils:

    Bug 143308
     
  11. snaaps

    snaaps Member

    Joined:
    Oct 8, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Nice but I have still the problem! Its stupid to everytime chanche /etc/gshadow.good!
    Is there not a fix for this problem?

    I run grpck -r, but its still go on! there is no end!
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No
    shadow group dip: no user
    delete member `'? No

    now he is about 2 oure busy white this seems there is no end!



    p.s how do I kill grpck in shell?
     
    #11 snaaps, Dec 29, 2004
    Last edited: Dec 29, 2004
  12. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    Ok. But why should I use that new (.good) file each time I remove my account?
     
  13. snaaps

    snaaps Member

    Joined:
    Oct 8, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Ok its a bug in fedora core.

    I have searche for a soulotion on the site from fedora but I cant find nothing.
    How do whe fix this problem?

    I can run a update to fedora core 3 but I think this is a stuppid eady.
     
  14. promak

    promak Well-Known Member

    Joined:
    Oct 6, 2001
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    16
    oh how can we do now?

    can only suspend account?

    :mad:
     
  15. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Currently you have limited options. These are your options IMO from best to worst:

    1. Install a new version of shadow-utils, either from source or source rpm.

    2. disable grpck, by either chmod'ing it or renaming it and placing a do-nothing script in its place.

    3. waiting for the fedora developers to release a new version of shadow-utils.

    That's the best I can suggest.
     
  16. hostcp3

    hostcp3 Well-Known Member

    Joined:
    Jun 18, 2002
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    you don't need to save a gshadow.good file, just run

    grpconv

    from ssh and that restores gshadow.

    also edit

    /etc/quota.conf as its not removing the entries from there also.
     
  17. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:

    Well. This bug it's unconfirmed by developers.

    Also, why this bug work only on Cpanel systems ?

    On my machines i've webmin installed and with webmin can delete accounts without any problem. Also on a machine with plesk and Fedora any problem for delete account.

    I think that the porblme it's not Fedora. It's Fedora + Cpanel. :mad:
     
  18. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    No Problem:
    shadow-utils-4.0.3-21.i386.rpm

    Problem (AFAIK):
    >=shadow-utils-4.0.3-55

    If you install the older version and exclude it's automatic update in your yum configuration, then you shouldn't have this issue. However, I'm sure it was updated for some reason, so proceed at your own risk. If you'd like to contribute to this bug's resolution, then let the Fedora developers know that it's a problem for you as well. cPanel does not fix bugs in standard system packages unless there are mitigating cirumstances. Since it worked at one point, then I'm sure the Fedora developers are capable of addressing this issue.
     
  19. CamronFry

    CamronFry BANNED

    Joined:
    Jan 1, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    0
    What is correct syntax for doing this?
     
  20. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0

    How do you disable grpck exactly? Please provide command/chmod preferred setting you recommend. Thank you
     
Loading...

Share This Page