The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem upgrading from Apache 1.3 to Apache 2.2

Discussion in 'EasyApache' started by cookiesunshinex, Dec 9, 2009.

  1. cookiesunshinex

    cookiesunshinex Well-Known Member

    Joined:
    Jun 10, 2005
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    I just wanted to post this in case someone else has the same problem.

    I just upgraded Apache from 1.3 to 2.2 using EasyApache 3.

    I had previously (a few months ago) upgraded to MySQL 5 and PHP 5.2.9 without any problems.

    So I was only changing the version of Apache.

    The first time I ran the update process, it failed and restored the Apache 1.3 configuration file and restarted Apache.

    This is the error I received:
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs"

    I looked in my .conf files and made sure that there were not extra lines that said "listen"

    I also ran the script to check the format of my .conf file. It did not find any problem with my httpd.conf file.

    Here is the command you use to do that:
    # /usr/local/apache/bin/apachectl configtest

    So I decided to just try re-running the update process. The second time it worked without any problems.

    After going through all of my accounts, I did not find any problems except a .htaccess file on a couple of wordpress blogs where we had made a change to fix the upload for the older (non flash) version of Wordpress. We have since updated to a newer version of Wordpress that has a flash upload function built in, so it's not needed anyway.

    Everything else was all good.
     
Loading...

Share This Page