The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem upgrading PHP to 4.3.10

Discussion in 'General Discussion' started by alrock, Jan 2, 2005.

  1. alrock

    alrock Active Member

    Joined:
    May 31, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    I am trying to upgrade php to 4.3.10 and I am having a bit of difficulty.

    I tried upgrading through /scripts/easyapache and checked version info, which still indicated version 4.3.9.

    Tried using WHM and selecting php version 4.3.10 . That did not work either.

    So I renamed /home/cpapachebuild and tried running /scripts/easyapache again. This time I watched it carefully and I see these errors:

    configure php-4.3.10...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --enable-versioning --with-zlib).................Done
    configure: error: Problem with libXpm.(a|so) or libX11.(a|so). Please check config.log for more information.

    Has anybody seen this before?
     
  2. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    cd /usr/ports/x11/libXpm
    make install clean

    then run easyapache again. :cool:
     
  3. alrock

    alrock Active Member

    Joined:
    May 31, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    I don't have a directory like that anywhere.

    I have:

    /usr/lib/libXpm.so

    and I have /etc/X11
     
    #3 alrock, Jan 3, 2005
    Last edited: Jan 3, 2005
Loading...

Share This Page