Problem using "PHP Extensions and Applications Package Installer"

sahostking

Well-Known Member
May 15, 2012
366
8
68
Cape Town, South Africa
cPanel Access Level
Root Administrator
Twitter
Whe my customers click show available system variables they get a blank page.

If I login to WHM with root and go to Module Installers and click: PHP Extensions and Applications Package
I see no extensions installed.
Though when I initially installed it before customizing Cpanel with EasyApache,etc. I could see a few extensions.

I reinstalled twice with the same outcome.

Also when I try to search for a extension I get the following under Search PHP Extension(s) and Application(s):
libgcc_s.so.1 must be installed for pthread_cancel to work
The above appears in the CPanel error log whenever attempted.

Any ideas?
Using Cloudlinux, updated fully. CPanel Release version 11.32.25, VPS.
 

sahostking

Well-Known Member
May 15, 2012
366
8
68
Cape Town, South Africa
cPanel Access Level
Root Administrator
Twitter
I followed this procedure again taking note of what happens each time.

1. Formatted disk
2. Reinstalled CPanel - All working at this point
3. Update Mysql 5.1 to 5.5 - All working after this was done
4. Ran Easyapache with PHP 5.3.10 and suphp and mysql and mysqli

After step 4 I got the same error returned when going to "PHP Extensions and Applications Package Installer"
libgcc_s.so.1 must be installed for pthread_cancel to work.
This happens on Cloudlinux install and CentOS.

I must be missing something. Just can't figure out what exactly it could be as I do no other changes besides the above when doing this install.

I have a feeling it's got to do with MySQL libraries.
 

jmonteiro

Registered
Jul 1, 2011
1
0
51
I have the same problem and can't find how it's happened
To have pages online i change PHP to DSO, but it's not a correction.

My server worked 3 day normal after upgrade MySQL.