Problem using SMTP to connect to cPanel email account

MilesTeg

Registered
May 7, 2020
2
0
1
mE06Mu64%87DU94UAb1hbEQUpcLQdG
cPanel Access Level
Root Administrator
Hello all,

After reading through countless topics in this forum I reached the conclusion that I need to ask for your help, because apparently I cannot figure out this issue on my own. This is my first dedicated server where I install cPanel, mostly to manage my own websites, so I don't have a lot of experience in managing a dedicated server.

To recap what I did to get to this point, in WHM I have created an account for my domain, example.com and I also created an email address in that cPanel account, [email protected]. Logging in the webmail account from cPanel allows me to send emails and I received them just fine in a gmail address (SPF and DKIM records are set up correctly).

But when I am trying to connect to that email address using an email client (Postbox from an Windows 10 machine) or using a Wordpress plugin (WP Mail SMTP) I am unsuccesful. I have attached a print screen with the error Postbox throws. It works with all other email accounts set up, so the issue is not on my machine.

I have whitelisted my IP in the cPHulk so that it's not blocking my IP. Checked the CSF logs to see if somehow I got banned, but I found nothing.

I have watched the /var/log/exim_mainlog file like suggested in some topics, to see if there is a record when trying to connect so that I can pinpoint the cause of this issue. But there is none.

The domain is behind Cloudflare but I have greyclouded the mail.example.com subdomain. The domain has a valid SSL certificate installed on the server so it's not a SSL issue when using port 465. SMTP Restrictions setting is disabled. I am using CSF and the SMTP_BLOCK option is set to Off, SMTP_ALLOWLOCAL is set to On, SMTPAUTH_RESTRICT is set to OFF.

I really don't know what else to do do be able to connect to SMTP.

Please help!

Best regards,
Miles Teg
 

Attachments

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,251
313
Houston
Hello,


You should definitely be able to use the MX as the destination, but the hostname works as well. Instead of using the hostname and 465 did you try 587 with STARTTLS?