problem when installing lets encrypt

morteza3245

Well-Known Member
Sep 16, 2013
148
1
68
cPanel Access Level
Root Administrator
Hello
when i run this command:

/usr/local/cpanel/scripts/install_lets_encrypt_autossl_provider
it show me below error:

[[email protected] ~]# /usr/local/cpanel/scripts/install_lets_encrypt_autossl_provider
info [install_lets_encrypt_autossl_provider] Starting yum execution “--assumeyes --config /etc/yum.con f install cpanel-letsencrypt --disablerepo=epel”.
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
This system is receiving updates from CLN.
Loading mirror speeds from cached hostfile
* EA4: 208.74.123.61
* cpanel-addons-production-feed: 208.74.123.61
* cpanel-plugins: 208.74.123.61
* base: mirror.centos.org
Including mirror: xmlrpc.cln.cloudlinux.com
* cloudlinux-x86_64-server-7: xmlrpc.cln.cloudlinux.com
Resolving Dependencies
--> Running transaction check
---> Package cpanel-letsencrypt.noarch 0:2.28-1.1 will be installed
--> Finished Dependency Resolution


Total download size: 42 k
Installed size: 104 k
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction

Error in PREIN scriptlet in rpm package cpanel-letsencrypt-2.28-1.1.noarch
Verifying : cpanel-letsencrypt-2.28-1.1.noarch 1/1

Complete!
info [install_lets_encrypt_autossl_provider] Completed yum execution “--assumeyes --config /etc/yum.co nf install cpanel-letsencrypt --disablerepo=epel”: in 16.104 second(s).
Cpanel::Exception::IO::ExecError/(XID ye47gp) The system failed to execute yum with the arguments “--a ssumeyes --config /etc/yum.conf install cpanel-letsencrypt --disablerepo=epel” because of an error: Th e “/usr/bin/yum --assumeyes --config /etc/yum.conf install cpanel-letsencrypt --disablerepo=epel” comm and (process 1577647) reported error number 1 when it ended. : Error in PREIN scriptlet in rpm package cpanel-letsencrypt-2.28-1.1.noarch

at /usr/local/cpanel/Cpanel/SysPkgs/YUM.pm line 1017.
Cpanel::SysPkgs::YUM::_die_child_error(Cpanel::SafeRun::Object=HASH(0x198d6d0), "Error in PREI N scriptlet in rpm package cpanel-letsencrypt-2."..., "packages", ARRAY(0xc78478), "_args", ARRAY(0x14 73178)) called at /usr/local/cpanel/Cpanel/SysPkgs/YUM.pm line 998
Cpanel::SysPkgs::YUM::_exec_yum(Cpanel::SysPkgs::YUM=HASH(0x1aec898), "packages", ARRAY(0xc784 78), "_args", ARRAY(0x1473178)) called at /usr/local/cpanel/Cpanel/SysPkgs/YUM.pm line 928
Cpanel::SysPkgs::YUM::_call_yum(Cpanel::SysPkgs::YUM=HASH(0x1aec898), "packages", ARRAY(0xc784 78)) called at /usr/local/cpanel/Cpanel/SysPkgs/YUM.pm line 226
Cpanel::SysPkgs::YUM::install_packages(Cpanel::SysPkgs::YUM=HASH(0x1aec898), "packages", ARRAY (0xc78478)) called at /usr/local/cpanel/Cpanel/Plugins.pm line 40
Cpanel::Plugins::install_plugins("cpanel-letsencrypt") called at /usr/local/cpanel/scripts/ins tall_lets_encrypt_autossl_provider line 19
scripts::install_lets_encrypt_autossl_provider::run() called at /usr/local/cpanel/scripts/inst all_lets_encrypt_autossl_provider line 16
[[email protected] ~]#
how i should fix this?

Thanks.