Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Problem when use /scripts/installruby

Discussion in 'General Discussion' started by frontcode, Sep 22, 2013.

  1. frontcode

    frontcode Member

    Joined:
    Oct 21, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NL
    cPanel Access Level:
    Root Administrator
    Hello got a problem with the script that installs ruby..
    When i try to do that i get the following massage:

    Code:
    warn [installruby] Unable to locate gem binary.
    info [checkccompiler] /root/.cpanel/datastore/Cpanel::Sys::Compiler::test_compile_gcc
    C compiler (/usr/bin/gcc) OK (cached Sun Sep 22 20:11:44 2013)
    Tuned C compiler not available because it is not enabled
    info [installsqlite3] Sqlite3 is already installed.
    Installing rubygems version: 1.3.7
    Using Dir: /home/cprubygemsbuild/rubygems-1.3.7
    Setting up rubygems ...
    ./lib/rubygems.rb:11:in `require': no such file to load -- thread (LoadError)
            from ./lib/rubygems.rb:11
            from setup.rb:24:in `require'
            from setup.rb:24
    Removing source directory /home/cprubygemsbuild
    warn [installruby] Unable to locate gem binary.
    warn [installruby] Unable to locate gem binary.
    open3: exec of uninstall -I -x -a -v >1.8.25 rubygems-update failed at /usr/local/cpanel/Cpanel/SafeRun/Dynamic.pm line 86
    can someone help me to fix this..i must install FLVtool2 and it needs ruby for it..

    thank you..
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,895
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Please try adding the "force" flag to see if that allows the installation to proceed. EX:

    Code:
    /scripts/installruby --force
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. hackboys

    hackboys Active Member

    Joined:
    Feb 12, 2008
    Messages:
    32
    Likes Received:
    2
    Trophy Points:
    58
    Same problem! Please help! How to install ruby?

    Code:
    root@server [~]# /usr/local/cpanel/scripts/installruby
    Removing source directory /home/cprubybuild
    Installing rubygems version: 1.3.7
    Using Dir: /home/cprubygemsbuild/rubygems-1.3.7
    Setting up rubygems ...
    warn [installruby] rubygems install failed: Ruby is not installed; can't install rubygems
    
    Removing source directory /home/cprubygemsbuild
    warn [installruby] Unable to locate gem binary.
    warn [installruby] Unable to locate gem binary.
    open3: exec of uninstall -I -x -a -v >1.8.25 rubygems-update failed at /usr/local/cpanel/Cpanel/SafeRun/Dynamic.pm line 86
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,895
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Did you try the solution offered in my last response to this thread?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice