Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

problem with autoSSL at WHM

Discussion in 'Security' started by thanasis, Feb 8, 2018.

  1. thanasis

    thanasis Active Member

    Joined:
    Nov 24, 2017
    Messages:
    37
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Hello,

    at my new VPS, i have ssl at my cPanels, but i don't have at WHM.

    AutoSSL is on and the shared SSL certificate is at "server . com" (please see the attached picture)

    Any help?
     

    Attached Files:

  2. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    29
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    Hi @thanasis,

    What do the "Certificate Details" show at WHM > Service Configuration > Manager Service SSL Certificates? Does the following command provide any helpful output?
    Code:
    # /usr/local/cpanel/bin/checkallsslcerts
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. thanasis

    thanasis Active Member

    Joined:
    Nov 24, 2017
    Messages:
    37
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Hello @cPWilliamL
    the output is wrong...
    At Certificate Properties tab writes the old hostname.
    Can you help me how to change this?

    At Home »Networking Setup »Change Hostname i have the new Hostname
     
  4. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    29
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    Could you try the following commands?
    Code:
    # /usr/local/cpanel/bin/set_hostname put.hostname.here
    # /usr/local/cpanel/bin/checkallsslcerts
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. thanasis

    thanasis Active Member

    Joined:
    Nov 24, 2017
    Messages:
    37
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    I did it.
    The last lines from the output of the second command was:

    The system will check for the certificate for the ftp
    The system will attempt to verify that the certificate for the ftp
    The system will attempt to replace the cPanel Store provided certificate for the ftp newhostname.xxx
    oldhostname.xxx oldhostname.xxx

    At Service Configuration »Manage Service SSL Certificates, i see the same; the oldhostname.xxx
     
  6. thanasis

    thanasis Active Member

    Joined:
    Nov 24, 2017
    Messages:
    37
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    I pressed the Reset Certificate button at Service Configuration »Manage Service SSL CertificatesDocumentation
    Now i have the correct new-host at Certificate Properties tab, but still WHM is not secure...
     
  7. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    29
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    This may be an issue with SNI. Could you open a ticket via my signature so we can take a look? You can post the ticket number here so we can update the thread with the resolution.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. thanasis

    thanasis Active Member

    Joined:
    Nov 24, 2017
    Messages:
    37
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Thank you cPWilliamL,

    My ticket ID is: 9270139
     
  9. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    29
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    To follow up on this issue, it appears hostname SSL CRT's were specifically disabled via touch file(/var/cpanel/ssl/disable_auto_hostname_certificate). Removing the file below corrected the issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice