The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with backup

Discussion in 'Data Protection' started by sergio2004, Mar 2, 2009.

  1. sergio2004

    sergio2004 Well-Known Member

    Joined:
    Feb 28, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro
    Hi,

    Since last week all days after the daily backup run I received an email with the subjetc: The backup of XXXXX's account encountered errors on YYYY.YYYYY.com (xxxxx is the name of account and yyyy is the hostname of the server) and the message of it is:

    The backup of xxxxx's account encountered errors
    Please check /usr/local/cpanel/logs/error_log and /usr/local/cpanel/logs/cpbackup/1235966401.log for more information.

    But the error_log is empty and in the 1235966401.log show the below error:

    Copying homedir..../bin/gtar: ./public_ftp: Cannot savedir: Permission denied
    /bin/gtar: Error exit delayed from previous errors

    Which day this problem occour with a different account. Some times this error occours in two days in the same account then pass occour with another account.

    What is this and how can I fix this problem?

    Thank you.
     
  2. Daerious

    Daerious Registered

    Joined:
    Jul 21, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I know you are hoping this reply is a solution... but it isn't.

    I am having this same issue. Some of the files it is giving this error on are years old and have been backed up successfully for quite a long time. As in the previous poster's case, it is seemingly random which account has the error, and even which files in the account.

    Has anyone found a solution to this?

    Also, If you have also had this problem, if you can please reply and let me know it would help to sort out if this is a problem with cpanel or something the two of us have done inadvertently to cause the issues.

    Thanks
     
  3. Daerious

    Daerious Registered

    Joined:
    Jul 21, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    There is a post a few posts down from here that explains this :)
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:

    The message explains itself I think. A problem with the directory in the root of the account. If you check the permissions on the directory public_ftp you might find the perms are set to 000. (I did) Change the permissions to the correct perms 750 and that should take care of it.


    I had this come up on one account per might, 3 nights in a row. Each night I fixed it and the next another came up. They've stopped now after fixing the errors.

    FWIW, 1 was file perms, 1 was directory perms, 1 was an old MySQL database on an account that was in trouble. Running repair on that DB solved the error.

    HTH
     
  5. larwilliams

    larwilliams Active Member

    Joined:
    Apr 14, 2008
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I have used a simple bash script to chmod all public_ftp folders to 0750. Hopefully this fixes the error for me too :)
     
  6. sergio2004

    sergio2004 Well-Known Member

    Joined:
    Feb 28, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro
    I check and the permissions are ok. May be a problem (bug) with cpanel version. Today I will do a upgrade for the new version and then I post here if the problem stop.
     
  7. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Seems to be a cpanel bug. I don't change anything with the accounts and they backup fine the next night and it's someone elses' turn to not backup. Consistently 1 account per server has an error and it's a different one each night. I don't bother to try and find the problem as there is obviously no problem.

    Just a FYI.
     
  8. xprimer

    xprimer Registered

    Joined:
    Mar 1, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    It's not a bug, cpanel made some changes and cpbackup runs the pkgacct process as the account user. This means that it only takes into account files owned by that specific user.

    This is a real issue for servers not using suPHP ; basically cPanel forces you to switch to suPHP. At least if you need backups :)

    Adrian
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Obviously? :p
     
  10. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Obviously because:
    1. Only one email is sent even though multiple accounts fail backup.
    2. Sometimes no email is sent even though multiple accounts fail backup.

    I don't know what's going through cPanels heads because the server backup is now completely unreliable. A reliable backup script is urgently needed.
     
  11. sergio2004

    sergio2004 Well-Known Member

    Joined:
    Feb 28, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro
    Since my last post here, I make the update the cpanel for cPanel 11.24.4-R34599.
    My server is with suPHP and the perms are ok. And all days I receive the message of the error.

    The complete log of one account (user_account is the name of the user and domain_name is the name of domain) is below.

    pkgacct started.
    pkgacct version 8.3 - user : user_account - archive version: 3 - running with uid 0
    Copying Reseller Config...Done
    Copying Suspension Info (if needed)...Done
    Copying SSL Certificates, CSRS, and Keys...Done
    Copying Counter Data....Done
    Copying Bandwidth Data.......domain_name.com...Done
    Copying Dns Zones.......domain_name.com...Done
    Copying Mail files....Done
    Copying frontpage files....Done
    Copying proftpd file....Done
    Copy userdata............
    Copy custom virtualhost templates............
    Done
    Grabbing PostgreSQL databases............
    psql: FATAL: semctl(229383, 3, SETVAL, 0) failed: Invalid argument
    Done
    Grabbing PostgreSQL privileges...psql: FATAL: semctl(229383, 3, SETVAL, 0) failed: Invalid argument
    psql: FATAL: semctl(229383, 3, SETVAL, 0) failed: Invalid argument
    Done
    Leaving timeout safety mode
    Copying mailman lists....Done
    Copying mailman archives....Done
    Copying homedir..../bin/gtar: ./public_ftp: Cannot savedir: Permission denied
    /bin/gtar: Error exit delayed from previous errors
    Done
    Entering timeout safety mode
    Grabbing mysql dbs........horde.turba_objects horde.horde_prefs horde.kronolith_events horde.kronolith_storage horde.mnemo_memos horde.nag_tasks ...Done
    Grabbing mysql privs...Done
    Copying cpuser file.......Done
    Copying crontab file.......Done
    Copying quota info.......Done
    Storing Subdomains....
    Done
    Storing Parked Domains....
    Done
    Storing Addon Domains....
    Done
    Storing ssl domain......Done
    Copying password.......Done
    Copying shell.......Done
    pkgacctfile is: /backup/cpbackup/daily/user_account.tar.gz
    Creating Archive ....Done
    md5sum is: a96b9bc25aef2abfe4e59757ba523dc0

    I would like the cPanel staff talk anything about this problem. Is it possible?

    Thank you.
     
  12. sergio2004

    sergio2004 Well-Known Member

    Joined:
    Feb 28, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro
    Any tip or solution?

    Thanks
     
  13. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Sure, already posted above.

    From the error:

    Reset the permissions on the directory on that account called public_ftp
     
  14. jdh8383

    jdh8383 Registered

    Joined:
    Jun 3, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I have quite same problem with you. The permissions on pulic_ftp of certain users just became 000 for no reason.
    I did nothing but update my server to latest RELEASE version a few days ago.
     
  15. AnilR

    AnilR Active Member

    Joined:
    Nov 24, 2007
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    change the permission of public_ftp folder to 755 and update cpanel with STABLE release.

    It should work !! :)
     
  16. eagle

    eagle Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Even if you don't change anything to the permissions, you won't get the same error the next time.

    The first time I read those messages,I ran to the dir to fix what 'was wrong'. In fact, I found a dir that was owned by someone else than the account. So, fixed it ;) . The next time I did nothing, and the next day no error was thrown.

    I think it might have something to do with a file being used while being backupped....
     
  17. eagle

    eagle Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Just to mention as a update.

    I get errors thrown on different accounts now every day, without ever touching any file. So there must be a mechanism behind this :p
     
  18. esolutions

    esolutions Member

    Joined:
    Aug 16, 2006
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I have this same message in my logs.

    Code:
    Copying homedir..../bin/gtar: ./public_ftp: Cannot savedir: Permission denied
    /bin/gtar: Error exit delayed from previous errors
    
    After some research I found that cPanel is changing the permissions of /home/<username>/public_ftp when the account is suspended.

    I verified that the home directory is indeed added to the backup and that the backup itself is successful (the modification time on the tar.gz file in my backup folder is correct). The public_ftp folder is not being backed up.

    Does anyone (preferably a cPanel staff member) know if this is the desired behavior. If so, is there a way to stop the notifications about this issue from coming every time a suspended account is backed up?

    I am using cPanel 11.24.4-R34599 - WHM 11.24.2 - X 3.9
     
  19. sergio2004

    sergio2004 Well-Known Member

    Joined:
    Feb 28, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro
    I am using cPanel 11.24.4-C34851 (Current) and the same thing occour.
     
  20. FearlessG1

    FearlessG1 Active Member

    Joined:
    May 5, 2006
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    I to am getting random backup errors on different accounts every night. Sometimes the backup will go completely fine then other nights the account that fails to backup is different, just random actually.
     
Loading...

Share This Page