The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with ClamAV

Discussion in 'General Discussion' started by amedeods, Apr 20, 2010.

  1. amedeods

    amedeods Registered

    Joined:
    Nov 13, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I've installed ClamAV (clamavconnector) from the WHM/Cpanel plugin manager; the installation process is successful but when I try to launch a scan on a ftp-space I see that the process hangs; it seems that the clamd daemon is not started. The web interface displays the message:

    Scanning:
    ... connecting to clamd service ...

    but it doesn't go on.

    The installed addon details are the following:

    Name: clamavconnector
    Author: cPanel Inc.
    Installed Version: 0.95.3-2.2
    Version: 0.95.3-2.2
    Description: Virus Protection for Email and Filemanager Uploads !!BETA VERSION!!
    Price: free

    What can I do?

    Amedeo
     
  2. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Is clamd running?

    Check to make sure that the clamd service is running. The ps aux command, piped to grep, should give you something like this:

    Code:
    # ps aux|grep -i clamd
    root     11599  0.0  9.1 115948 93784 ?        Ssl  Apr08   1:10 /usr/sbin/clamd
    If no clamd process is listed, try restarting clamd:

    Code:
    # /scripts/restartsrv_clamd
    # ps aux|grep -i clamd
    Are any errors displayed when you run these commands? Also, are any errors logged to /usr/local/cpanel/logs/error_log when you try to start a scan? You can use tail to watch the log while starting a scan:

    Code:
    # tail -f /usr/local/cpanel/logs/error_log
     
  3. mzcorp

    mzcorp Member

    Joined:
    Aug 14, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Dear Team,

    I am trying to scan an account through ClamAV here it is:

    Scanning:
    ... connecting to clamd service ...

    It does not go further.

    I use following "# ps aux|grep -i clamd" command from your this post.
    After that following message appear:

    root 8089 0.0 0.0 3996 748 pts/0 S+ 05:37 0:00 grep -i clamd

    Then i try to restart it through following command:
    # /scripts/restartsrv_clamd

    Then following message came:
    clamd: no process killed
    clamd: no process killed

    Please check and guide to set it as running.


    Regards,
    Umer Khokhar
     
  4. kuldeep_

    kuldeep_ Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6

    Try reinstalling clamavconnector from WHM >> cPanel >> Manage Plugins >> select clamavconnector and at the bottom select Save.
     
  5. JawadArshad

    JawadArshad Well-Known Member
    PartnerNOC

    Joined:
    Apr 8, 2008
    Messages:
    447
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    PK
    cPanel Access Level:
    DataCenter Provider
    Umer, I posted a checklist in another thread and it has almost always resolved the issue. You can check the post here. I hope it resolves your problem.
    If you want to expedite this, you can open a ticket with cPanel support.

     
  6. diddycentre

    diddycentre Member

    Joined:
    Jul 20, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    hi there, when i try check error log

    # tail -f /usr/local/cpanel/logs/error_log
    ================================================
    make[4]: *** [libclamavcxx_la-bytecode2llvm.lo] Error 1
    make[3]: *** [install] Error 2
    make[2]: *** [install-recursive] Error 1
    make[1]: *** [install] Error 2
    make: *** [install-recursive] Error 1
    ln: creating symbolic link `./freshclam' to `../../bin/freshclam': File exists
    Can't open /etc/freshclam.conf: No such file or directory.
    ./install: line 113: /usr/bin/freshclam: No such file or directory
    mkdir: cannot create directory `/usr/local/cpanel/base/frontend/x/cells/': File exists
    ln: creating symbolic link `./cells' to `../x/cells': File exists
    [2010-11-02 21:00:59 +0800] warn [addon_clamavconnector] User file '/var/cpanel/ users/root' is empty or non-existent. at /usr/local/cpanel/Cpanel/Config/LoadCpU serFile.pm line 35
    Cpanel::Config::LoadCpUserFile::load('root') called at /usr/local/cpanel /Cpanel/Config/LoadCpUserFile.pm line 158
    Cpanel::Config::LoadCpUserFile::loadcpuserfile('root') called at /usr/lo cal/cpanel/Cpanel.pm line 96
    Cpanel::initcp('root') called at /usr/local/cpanel/whostmgr/docroot/cgi/ addon_clamavconnector.cgi line 32
    [2010-11-02 21:01:08 +0800] warn [addon_clamavconnector] User file '/var/cpanel/ users/root' is empty or non-existent. at /usr/local/cpanel/Cpanel/Config/LoadCpU serFile.pm line 35
    Cpanel::Config::LoadCpUserFile::load('root') called at /usr/local/cpanel /Cpanel/Config/LoadCpUserFile.pm line 158
    Cpanel::Config::LoadCpUserFile::loadcpuserfile('root') called at /usr/lo cal/cpanel/Cpanel.pm line 96
    Cpanel::initcp('root') called at /usr/local/cpanel/whostmgr/docroot/cgi/ addon_clamavconnector.cgi line 32
    [2010-11-02 21:01:13 +0800] warn [addon_clamavconnector] User file '/var/cpanel/ users/root' is empty or non-existent. at /usr/local/cpanel/Cpanel/Config/LoadCpU serFile.pm line 35
    Cpanel::Config::LoadCpUserFile::load('root') called at /usr/local/cpanel /Cpanel/Config/LoadCpUserFile.pm line 158
    Cpanel::Config::LoadCpUserFile::loadcpuserfile('root') called at /usr/lo cal/cpanel/Cpanel.pm line 96
    Cpanel::initcp('root') called at /usr/local/cpanel/whostmgr/docroot/cgi/ addon_clamavconnector.cgi line 32
    ================================================

    how can i solve this problem ???
     
  7. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Reinstall ClamAV

    From the output provided, it appears that ClamAV was not installed completely. In Main >> Server Configuration >> Tweak Settings, check the value for The maximum memory a cPanel process can use before it is killed off (in megabytes). It is likely the default, 256. Change it to 512. Then, uninstall and reinstall ClamAV using Main >> cPanel >> Manage Plugins.

    It should take much longer to install ClamAV this time, and it should work when the installation is finished.

    The issue of the memory limit causing plugins not to install completely is known by our developers, and there is an internal bug report for this issue. There is no estimate for when this is corrected, but the workaround for now, if a plugin fails to install completely due to the memory limit, is to raise the limit to 512 or more.

    If raising the limit and reinstalling ClamAV does not fix the problem on your server, please submit a ticket so that we may investigate directly, because it may be caused by a different problem.
     
Loading...

Share This Page