The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with configserver interface

Discussion in 'General Discussion' started by urgido, Sep 3, 2016.

  1. urgido

    urgido Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    66
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi
    I got blank page when I try to use configserver interface through WHM.

    My log:
    "trim_html" is not exported by the Cpanel::StringFunc::Trim module
    Can't continue after import errors at /usr/local/cpanel/Whostmgr/HTMLInterface/Output.pm line 8.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Whostmgr/HTMLInterface/Output.pm line 8.
    Compilation failed in require at /usr/local/cpanel/Whostmgr/HTMLInterface/Exec.pm line 12.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Whostmgr/HTMLInterface/Exec.pm line 12.
    Compilation failed in require at /usr/local/cpanel/Whostmgr/HTMLInterface.pm line 14.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Whostmgr/HTMLInterface.pm line 14.
    Compilation failed in require at /usr/local/cpanel/whostmgr/docroot/cgi/addon_csf.cgi line 23.
    BEGIN failed--compilation aborted at /usr/local/cpanel/whostmgr/docroot/cgi/addon_csf.cgi line 23.
    Internal Server Error: "GET /cpsess8836187302/cgi/addon_csf.cgi HTTP/1.1" 500 No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/addon_csf.cgi) with exit signal: 9


    How I can solve this? Bless
     
  2. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    317
    Likes Received:
    23
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,
    Try to run the following command to get your csf scripts up to date
    Code:
    curl -s configserver.com/free/csupdate|perl
    
     
  3. urgido

    urgido Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    66
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Thanks for your reply, here is the output

    Bareword found where operator expected at - line 3, near "404 Not"
    (Missing operator before Not?)
    Bareword found where operator expected at - line 5, near "<h1>Not Found</h1"
    (Might be a runaway multi-line // string starting on line 4)
    (Missing operator before h1?)
    Bareword found where operator expected at - line 6, near "<p>The"
    (Missing operator before The?)
    Number found where operator expected at - line 7, near "a 404"
    (Do you need to predeclare a?)
    Bareword found where operator expected at - line 7, near "404 Not"
    (Missing operator before Not?)
    Bareword found where operator expected at - line 9, near "/body></html"
    (Missing operator before html?)
    syntax error at - line 2, near "html>"
    "use" not allowed in expression at - line 8, at end of line
    Execution of - aborted due to compilation errors.


    You solution is posted in many blogs but don't works for me.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You should ask your question about this over on CSF forums.

    Is your cPanel up to date?
     
Loading...

Share This Page