maxime

Member
Aug 13, 2001
16
0
301
Hi,

When trying to restart cppop, I get an error message:

/scripts/restartsrv_cppop
Waiting for cppop to shutdown......Done
Waiting for cppop-ssl to shutdown......Done
Can't use an undefined value as a symbol reference at bin/cppop-ssl.pl line 447.

Any idea what is corrupt or missing ?

Thanks,

Maxime
 

shaun

Well-Known Member
PartnerNOC
Verifed Vendor
Nov 9, 2001
708
1
318
San Clemente, Ca
cPanel Access Level
DataCenter Provider
Twitter
Since cpanel has converted to using maildir as it's primary setup we've seen nothing but problems with cppop. Weird because you think it would just work as it did in the future.. I would recommend you just convert to maildir

/scripts/convert2maildir

It's a very simple process.
 

devGOD

Well-Known Member
Oct 18, 2003
122
0
166
Atlanta, GA
was this recently the update to maildir? cause i'm having problems connecting to my mail server this happened after i rebooted the server. what exactly will happen after i run /scripts/convert2maildir ?
 

totally_cliched

Registered
Nov 10, 2006
3
0
151
tried convert2maildir, now exim not working!

i tried /scripts/convert2maildir
it said it was complete, then no mail was coming through (just sitting in the queue).

doing a tail on the log-

[email protected] [/]# tail -f /var/cpanel/updatelogs/maildirconversion.1200318100

Normal Startup Proceeding.
Can't use an undefined value as a symbol reference at bin/cppop-ssl.pl line 499.
Cpanel License is not activated
Gathering header information file(s) from server(s)
Server: Dag RPM Repository for Red Hat Enterprise Linux
Finding updated packages
Downloading needed headers
No actions to take
Unable to install courier. at /usr/local/cpanel/bin/maildirupdate line 72.
so it didn't do the conversion. mail just sitting in the queue not being delivered.

now exim won't start with the original mbox config.

[email protected] [/]# service exim status
exim dead but subsys locked
[email protected] [/]# service exim restart
Shutting down exim: [FAILED]
Shutting down antirelayd: [ OK ]
Shutting down spamd: [ OK ]
Starting exim-26: execvp: No such file or directory
[FAILED]
Starting exim: execvp: No such file or directory
[FAILED]
Starting exim-smtps: execvp: No such file or directory
[FAILED]
Starting antirelayd: [ OK ]
Starting spamd: [ OK ]
i have tried killing all exim relating processes and ALL the exim related cpanel config/update scripts. this is on redhat VPS.