The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with dnstransfer

Discussion in 'Bind / DNS / Nameserver Issues' started by Grzes, Jan 22, 2004.

  1. Grzes

    Grzes Member

    Joined:
    Aug 12, 2001
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Poland
    I have two servers:
    ns1.domain.com (master)
    ns2.domain.com (slave)
    And everything work correct.
    But now I add third server:
    ns3.domain.com (slave)
    All seting is correct.
    When I run WHM/Synchronize DNS Records with Primary Nameserver there is report:
    Code:
    Rebuilding DNS Zones List from master server .....
    Rebuild Complete
    
    When I run SSH
    /scripts/dnstransfer
    there is report
    Code:
    Rebuilding DNS Zones List from master server .....
    stdin: is not a tty
    named.conf                                    100%   50KB  47.7KB/s   00:01
    Rebuild Complete
    However /var/named/ is empty.
    When I look at /var/log/messages of master server there is:
    Code:
    Jan 22 14:33:56 dns named[18630]: client xxx.xx.xxx.xxx#42761: transfer of 'mydomain.com/IN': AXFR started
    Jan 22 14:33:56 dns named[18630]: client xxx.xx.xxx.xxx#42762: transfer of 'mydomain.org/IN': AXFR started
    But when I look at /var/log/messages of slave server (ns3) there is:
    Code:
    Jan 22 14:32:52 hosting named[3441]: dumping master file: /var/named/tmp-XXXX8lG3b2: open: permission denied
    Jan 22 14:32:52 hosting named[3441]: transfer of 'mydomain.com.pl/IN' from xx.xx.xx.xx#53: failed while receiving responses: permission denied
    Jan 22 14:32:52 hosting named[3441]: transfer of 'mydomain.com.pl/IN' from xx.xx.xx.xx#53: end of transfer
    What can I do with it?
     
  2. efeito

    efeito Well-Known Member
    PartnerNOC

    Joined:
    Jul 24, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    .pt
    what are the OS of both servers?
     
  3. Grzes

    Grzes Member

    Joined:
    Aug 12, 2001
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Poland
    master - RedHat 7.2
    slave - RedHat Enterprise 3
     
  4. efeito

    efeito Well-Known Member
    PartnerNOC

    Joined:
    Jul 24, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    .pt
    Thats your problem!

    PM me your email and i will try to help you :)
     
  5. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    dns problem still

    sorry all...
    I don't think the os version is the cause. I am seeing the similar thing.

    I am running ES 3.0 on both servers. They are both up-to-date on the OS level from about a week ago.

    I've got the trust relationship working, but the synchronize doesn't copy over the domains.

    dnstransfer runs and says transfer complete, but I don't see the files in the /var/named directory.
     
  6. efeito

    efeito Well-Known Member
    PartnerNOC

    Joined:
    Jul 24, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    .pt
    Maybe your problem is a different one, check logs for the error. But on his case is the OS.

    RHEL uses different permissions.
     
  7. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Well,

    I manually copied over the files from /var/named from the primary server to the secondary server. I guess I needed to help it along with the primary sync. Now when I make domain changes on any of the servers, it updates back with the primary, so I think it should be ok.
     
  8. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    ok. I give up (finally). I've started a support ticket on this, but as I re-read all the messages, it seems like I may have the same issue.

    both of my nameservers are using RHEL. I get permission denied errors when I run the dnstransfer script and the zone files are not getting copied over.

    Is there some help that should be posted to the forum for others with the same problem? Otherwise I will wait to see what the result of the trouble ticket bring.
     
  9. hbouma

    hbouma Well-Known Member

    Joined:
    Jun 8, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    efeito,

    I am having the same problem. The slave server is RHE and the master is 7.3. How do I adjust the permissions to fix the problem? Thanks.

    Hal
     
  10. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    I don't know if this will help... but here is what I did...

    on both servers:

    cd /var
    chown -r named.named named

    then run /scripts/dnstransfer
    restart your bind on both servers.

    mine seems to be working now.
     
  11. hbouma

    hbouma Well-Known Member

    Joined:
    Jun 8, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    That did the trick for me on the RHE server as the named folder was root.named instead of named.named. Thanks!

    Hal
     
  12. wipl_piyush

    wipl_piyush Well-Known Member

    Joined:
    Oct 31, 2003
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY
    Im Trying a Master/Slave DNS setup in my LAN with Redhat ES 3.0 on both Master and Slave. But when the zone transfer innitistes it give the following error on Slave Server.

    Aug 25 12:45:33 server named[3220]: dumping master file: tmp-XXXX5ckUwv: open: permission denied
    Aug 25 12:45:33 server named[3220]: transfer of 'maiet.com/IN' from 192.168.0.250#53: failed while receiving responses: permission denied
    Aug 25 12:45:33 server named[3220]: transfer of 'maiet.com/IN' from 192.168.0.250#53: end of transfer

    Any idea .......
     
  13. rprix

    rprix Member

    Joined:
    Oct 27, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    check /var/named permissions,
    probably there is some root:named or root:root, and to fix it all must be named:named

    I fixed that but next problem is that zones are created ok, but not updated when changed on master server.

    - Changing zone info and serial: ok
    - Restarting master named: ok
    - Restarting secondary named to get zones reloaded: Old serial is readed and don't update zone

    (WHM 9.4.0 cPanel 9.4.1-R64)
    I readed in changelog from new versions something about cached-nameserver... is a fix for this?
     
  14. wipl_piyush

    wipl_piyush Well-Known Member

    Joined:
    Oct 31, 2003
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY
    well Thanks for the reply....i ll checkit out
     
Loading...

Share This Page