The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Domainkeys

Discussion in 'E-mail Discussions' started by ukzembla, Mar 3, 2010.

  1. ukzembla

    ukzembla Member

    Joined:
    Feb 9, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I totally can't get domainkeys to work: I've got an account blah.com set up on its own unique IP, reverse DNS works correctly, SPF is fine too. I've enabled domain keys using that domain's cPanel setting, and something which looks correct does appear on the DNS (see below) but ALL tests fail. I've tried the one at DomainKeys test, DomainKey Policy Record Tester (says "No _domainkey TXT record found for domain.com"), autorespond+dk@dk.elandsys.com and they all fail.

    The only one that yields anything is the selector record tester from DomainKey Selector Record Tester, which says "This selector appears valid"

    Should exim be adding extra headers to email it sends out that contain DomainKeys info? I'm not seeing anything if that's the case.

    DNS entries made by cPanel:

    Domain: default._domainkey
    TTL: 14400
    IN
    Record type: TXT
    "k=rsa; p=MHwwDQYJKoZIhvcNAQEBBQADawBwaAJhKNvi87jZnFKA3YMlsTE+VxpaNcfqmBS5CvfzYbFeWKrikD+YB/9pnIuVxmpv8kv1YzbgWLu+Vs8yrM1V+HfRjO3eEvKPv9HfgZThJ1nvLrfHzQfPulsTL96i8mwCNDGXjwIDAQAB;"

    I tried restarting named AND exim after these changes and nothing seemed to help... I'd REALLY appreciate any help on this, I've been banging my head against the wall for ages now and our emails keep getting put in the spam bin.

    Thanks!

    Alex
     
  2. beiruthost

    beiruthost Member

    Joined:
    Jul 27, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Same Problem

    I have the same problem
     
  3. ukzembla

    ukzembla Member

    Joined:
    Feb 9, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I've raised a support ticket about this so I'll let you know if I fix it. Incidentally though, I noticed that that command doesn't create the DK policy record, which doesn't have the selector and should prob look something like this:

    _domainkey 14400 IN TXT "o=~"

    Still didn't end up signing email though...
     
  4. GrynGe

    GrynGe Registered

    Joined:
    Jun 23, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I wonder has this problem been fixed yet or is there a way to fix it.
     
  5. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    If possible, please let me know the ticket ID number of the support request; I would like to follow-up and check internally with colleagues on what was concluded and or what the applicable outcome was that resulted from an investigation of the specific circumstances.
     
  6. beiruthost

    beiruthost Member

    Joined:
    Jul 27, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    any news ?
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Did you open up a ticket as well about your issue? It might not be the same reason as the other user and no specific details were provided on your prior post to detail what was happening in your instance, while the initial poster provided a great many details on their domain and settings.

    If you would like to post your ticket ID number upon opening one, we would be happy to look into what is happening for you.

    You can open up a ticket in WHM > Support Center > Contact cPanel or using the link in my signature.
     
Loading...

Share This Page