The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with easyapache

Discussion in 'EasyApache' started by hikaro, Nov 1, 2007.

  1. hikaro

    hikaro Well-Known Member

    Joined:
    Nov 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    easyapache not working and it gives output error

    ] at /usr/local/cpanel/bin/apache_conf_distiller line 533, <HTTPDCONF> line 420.
    !! '/usr/local/cpanel/bin/apache_conf_distiller --update' failed with exit code '2304' !!
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Are you running the latest build of EasyApache 3? The latest build is currently 2962 according to http://changelog.cpanel.net . If not, go to WHM -> cPanel -> Upgrade to Latest Version to update.

    If you are on the latest build, please submit a ticket directly to us here at cPanel regarding your EA3 issue.
     
  3. infinityws

    infinityws Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    and I always get this error. Running A build of easyapache on release 3072


    !! Could not ensure pkglist 'zlib1-devel, expat-devel, gettext, automake19, libpng-devel, libopenssl0-dev, expat, openssl, gcc-c++, glibc-devel, libpng-dev, zlib-devel, libstdc++, zlib, bison, autoconf261, libidn-devel, libidn, gmake, libXpm, libstdc++-devel, libjpeg-devel, openssl-devel, automake, coreutils, libtool-libltdl-devel, libopenssl0, openssl-dev, libtool, patch, libstdc++-dev, libz-devel, libltdl3-devel, libltdl, libjpeg-dev, libopenssl0.9.7-static-devel, pam-dev, libtool-ltdl-devel, libopenssl0.9.7-devel, libltdl-devel, fileutils, libXpm-devel, sed, libXpm-dev, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, make, xorg-x11-devel, libssl-dev, gd, pam-devel, cpp, xorg-x11-dev, gcc, libopenssl0-devel, ssl-dev, lex, autoconf' !!
    !! Please visit http://www.cpanel.net/support/could_not_ensurepkgs.htm for help with this error. !!
    !! Restoring original working apache !!
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    Compiling report...
    Sending report (16064 bytes)...
    !! If you want to create a support ticket with cPanel regarding this please reference 'BuildAP Report Id': '478363' !!
    Report processed.
    !! Feel free to submit a support ticket at https://tickets.cpanel.net/submit/index.cgi?reqtype=tickets !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1194383460' !!
     
  4. ashokpomnar

    ashokpomnar Active Member

    Joined:
    Sep 30, 2006
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    I am also trying to upgrade apache/php on new installed capenel server but getting samer error.

    ***********************************************************************
    Dependencies Resolved
    =============================================================================
    Package Arch Version Repository Size
    =============================================================================
    Installing:
    gd i386 2.0.28-5.4E base 119 k
    xorg-x11-devel i386 6.8.2-1.EL.31 update 5.1 M
    Installing for dependencies:
    fontconfig i386 2.2.3-7.centos4 base 117 k
    freetype i386 2.1.9-6.el4 update 763 k
    libpng i386 2:1.2.7-3.el4_5.1 update 155 k
    xorg-x11-Mesa-libGL i386 6.8.2-1.EL.31 update 383 k
    xorg-x11-libs i386 6.8.2-1.EL.31 update 2.7 M
    Transaction Summary
    =============================================================================
    Install 7 Package(s)
    Update 0 Package(s)
    Remove 0 Package(s)
    Total download size: 9.3 M
    Downloading Packages:
    Running Transaction Test
    Finished Transaction Test
    !! Could not ensure pkglist 'aspell, aspell-devel, automake19, gettext, libstdc++.x86_64, libpng-devel, openssl, libpng-dev, zlib-devel, autoconf261, libidn-devel, libidn, gmake, libXpm, openssl-devel, automake, coreutils, patch, libltdl3-devel, libltdl, libopenssl0.9.7-static-devel, libtool-ltdl-devel, libXpm-devel, sed, libXpm-dev, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, pspell-devel, libstdc++-devel.x64_64, xorg-x11-devel, libssl-dev, bzip2-devel, pam-devel, libopenssl0-devel, zlib1-devel, expat-devel, pspell, libopenssl0-dev, expat, glibc-devel, gcc-c++, zlib, bison, libjpeg-devel, libtool-libltdl-devel, libtool, openssl-dev, libopenssl0, bzip2-libs, libz-devel, libjpeg-dev, pam-dev, fileutils, libltdl-devel, libopenssl0.9.7-devel, make, libstdc++-dev.x86_64, libstdc++-devel.x86_64, gd, cpp, xorg-x11-dev, gcc, ssl-dev, autoconf, lex' !!
    !! Please visit http://www.cpanel.net/support/could_not_ensurepkgs.htm for help with this error. !!
    !! Restoring original working apache !!
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    Compiling report...
    Sending report (5292 bytes)...
    !! If you want to create a support ticket with cPanel regarding this please reference 'BuildAP Report Id': '520760' !!
    Report processed.
    !! Feel free to submit a support ticket at https://tickets.cpanel.net/submit/index.cgi?reqtype=tickets !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1197697250' !!

    ************************************************************************
     
  5. infinityws

    infinityws Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    This is ridiculous that no one has a fix for this. it is still happening on the latest release of CPanel 11.
     
  6. ashokpomnar

    ashokpomnar Active Member

    Joined:
    Sep 30, 2006
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Yes,I have tried lots of thing but no luck.
     
  7. ashokpomnar

    ashokpomnar Active Member

    Joined:
    Sep 30, 2006
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1

    Any update ?
     
  8. rvelton

    rvelton Member

    Joined:
    Oct 30, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Orange Country, CA
    Yeah, I am getting the same problem with no luck either. :(
     
  9. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
  10. infinityws

    infinityws Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    cpaneldavid: I sent in a request but it's not priority since I get cpanel from my server provider. All of which have no idea how to fix this issue.
     
  11. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    I'll take a look at it.
     
  12. agressor

    agressor Active Member

    Joined:
    May 15, 2005
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    no public fix for this ?
     
  13. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Keep in mind that even though many servers may experience the same issue, the cause of the issue may vary. We continually improve EasyApache based on issues that are brought to our attention via the ticket system (among other forms of feedback). As a result, the best solution for any EasyApache issue where a possible resolution isn't posted on a forum is to submit a support ticket. You can submit such a ticket at:

    http://tickets.cpanel.net/submit
     
  14. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The issues reported here pertain to problems with the YUM update system. One of the common causes for YUM failure is corrupted RPM database. Other common causes are broken dependencies in RPMs, bad mirrors and failed installs. The exact nature of the problem varies. The output of the EasyApache error message provides a link to documentation to help you resolve this error.

    To determine which error is happening on your system from the command line, attempt to YUM install a package, for example:

    Code:
    
    yum install gettext
    
    Based upon the output from that step, you can isolate which steps need performed to resolve the issue.
     
Loading...

Share This Page