The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with exim after upgrade

Discussion in 'General Discussion' started by magin, Jan 21, 2005.

  1. magin

    magin Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    45
    Likes Received:
    1
    Trophy Points:
    6
    I have several errors , cant send emails this is the errors in eximlog


    2005-01-21 14:42:07 failed to expand condition "${perl{check_deliver}{$domain}{$local_part}}" for virtual_user router: Undefined subroutine &main::check_deliver called.

    2005-01-21 14:42:07 failed to expand condition "${perl{checkusersa}{$local_part}{$received_protocol}}" for sa_localuser router: Undefined subroutine &main::checkusersa called.

    2005-01-21 14:42:07 failed to expand condition "${perl{checkuserspambox}{$local_part}}" for localuser_spam router: Undefined subroutine &main::checkuserspambox called.

    2005-01-21 14:42:07 failed to expand condition "${perl{checkuserbx}{$local_part}}" for boxtrapper_localuser router: Undefined subroutine &main::checkuserbx called.

    2005-01-21 14:42:08 H=ip69-62.ct.com (Servpub) [200.40.50.69] F=<serpub@muni.go> temporarily rejected RCPT <Alvarado@ibm.com>: failed to expand ACL string "${perl{checkrelayhost}{$sender_host_address}}": Undefined subroutine &main::checkrelayhost called.




    what can i do already try to upgrade cpanel, and reinstall exim but not success
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try upgrading to the latest exim4:

    /scripts/exim4 --latest
     
  3. magin

    magin Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    45
    Likes Received:
    1
    Trophy Points:
    6
    thanks Chirpy , already did it, but still have problem i realiza that exim.pl is missing

    any other way to try a solution?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I've attached the exim.pl for the exim 4.44 disti from cPanel, if that helps.
     

    Attached Files:

  5. magin

    magin Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    45
    Likes Received:
    1
    Trophy Points:
    6
    Thanks chirpy, now looks like its fixed the errors in the eximlog no more errors, but is not receiving mails, last days i installed your antidictionary attack scripts and it was working pretty good, also can you post the antivirus.exim it missing in my box too


    UPDATE,
    oK Already fixed it was Mailscanner issue

    chirpy thanks for your help
     
    #5 magin, Jan 21, 2005
    Last edited: Jan 21, 2005
Loading...

Share This Page