The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Exim configuration

Discussion in 'General Discussion' started by WhiteBear, May 25, 2006.

  1. WhiteBear

    WhiteBear Well-Known Member

    Joined:
    Feb 19, 2004
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Hello friends,

    Can you help me, please?

    I had access WHM > Exim Configuration Editor > Switch to Advanced Mode > Save....

    It appears this error:

    2006-05-25 19:09:40 Exim configuration error in line 905 of /etc/exim.conf.buildtest:
    user mailman was not found
    Exim version 4.52 #1 built 16-Aug-2005 05:07:45
    Copyright (c) University of Cambridge 2005
    Berkeley DB: Sleepycat Software: Berkeley DB 4.2.52: (December 11, 2004)
    Support for: iconv() PAM Perl OpenSSL Content_Scanning Old_Demime
    Lookups: lsearch wildlsearch nwildlsearch iplsearch dbm dbmnz
    Authenticators: cram_md5 plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile/maildir autoreply pipe smtp
    Configuration file has an invalid syntax. Please try again.

    Please you can inform me how to fix this problem?

    Tks a lot,
     
  2. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    REMOVE everything from all the boxes in the editor. Then save it. That will restore the default settings for Exim.
     
  3. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    18
    The problem lies within the default exim.conf. I have everything removed, but it is not recognizing user mailman.

    I don't use mailman on my servers, so I simply commented out:

    # user = mailman
    # group = mailman

    Below:

    mailman_virtual_transport:

    and

    mailman_virtual_transport_nodns:

    You'll probably have to chattr +i /etc/exim.conf

    otherwise cPanel will overwrite this on any upcp. I don't believe you can change this in the Exim configuration editor, it's not one of the text boxes. I wouldn't recommend this if you use mailman, as I'm not sure of the consequences. However, I did try enabling mailman prior to doing this and it didn't seem to correct the syntax error.

    Boy, lots of fun bugs with this new release.
     
  4. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    18
    Not sure why, but the Exim Configuration editor seems to be loading :

    /etc/exim.conf.mailman2.dist

    as the default template.

    I (after backing up, just in case):

    rm /etc/exim.conf.mailman2.dist
    rm /etc/exim.conf.mailman2.exiscan.dist

    and the exim configuration editor seems to load exim.conf.dist now. This seems to be a better solution than my post above.
     
  5. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
Loading...

Share This Page