Problem with exim , courier/pop3 server

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
when i download my emails in outlook express

i am getting following error

Message number 1 could not be retrieved. Account: 'mail.mydomain.com', Server: 'mail.mydomain.com', Protocol: POP3, Server Response: '-ERR Can't open the message file - it's gone!', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800420CD

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'mail.mydomain.com', Server: 'mail.mydomain.com', Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 10053, Error Number: 0x800CCC0F
Pls suggest what to do
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Could you try switching to IMAP to see if you still have issues with this happening? It seems that POP3 is terminating the connection unexpectedly. IMAP is a better protocol for message retrieval.
 

garrettp

Well-Known Member
PartnerNOC
Jun 18, 2004
312
1
166
cPanel Access Level
DataCenter Provider
Also, check /var/log/exim_mainlog for more clues. Sounds to me almost like you might have two POP3 devices fighting for mail.
 

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
Hi,

i got solutions :)

in the webmail there were few mails, from System Administrator with sub : message unavailable

And from the webmail i am unable to view, delete, forward or move those mails & which is causing this issue.

So i have logged in to SSH & found these files by running this command

ls -lah
-rw-rw---- 1 root root 1.8K Jan 22 12:45 1295680540.H404988P19775.myserver.domain.com,S\=1794:2,S
-rw-rw---- 1 root root 1.4K Jan 22 14:05 1295685348.H3552P12846.myserver.domain.com,S\=1432:2,
-rw-rw---- 1 root root 1.5K Jan 22 15:15 1295689542.H771861P7288.myserver.domain.com,S\=1464:2,
then i have changed ownership
by
Code:
chown cPuser.cPuser 1295680540.H404988P19775.myserver.domain.com,S\=1794:2,S 1295685348.H3552P12846.myserver.domain.com,S\=1432:2, 1295689542.H771861P7288.myserver.domain.com,S\=1464:2,
And then i did restart exim & check retrying mails in outlook express & mails were just receiving fine
problem got solved.

Thanks :)