The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with FTP DNS settings

Discussion in 'Bind / DNS / Nameserver Issues' started by ChrissHere, Dec 24, 2011.

  1. ChrissHere

    ChrissHere Member

    Joined:
    Aug 1, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hello everyone,
    I had to change the two main IPs of my webserver yesterday and now there seems to be a problem with the DNS Settings of every FTP subdomain.
    At first, yesterday, I added the domain but I forgot to make the IP shared, so I tried to change the IP of many sites to that one but only the first account (for example domain1.com) got the IP (since it was not shared), so the account domain1.com received it as a dedicated IP. Every webspace redirected then to that one webspace for a moment since the nameserver were already set for the new IP.
    I got it working so the IP is shared and every webspace has got the IP now as a shared one and every domain redirects (is "redirect" even the right word for it?) now to the right webspace. Everything okay so far.
    Now I have noticed if, for example, someone tries to access http://ftp.domain2.com he will see the normal website as if he would access http://domain1.com . This problem applies to all domains (domain3.com, domain4.com, etc.)
    Now I guess there is some problem with the DNS settings. Every DNS zone is set right, I checked it and every zone has got the right IP for "ftp" .
    My question is, how can I solve this issue? Is there a special config file to set it?
    Best regards and merry christmas,
    Chriss
     
  2. ChrissHere

    ChrissHere Member

    Joined:
    Aug 1, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Is there no Tech.Admin who can help me with this issue?
     
  3. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    The problem is not in the DNS Zones, but in Apache's httpd.conf.

    In that file there should be the 1st VirtualHost container like this:


    Code:
    <VirtualHost <main_shared_IP>:80>
        ServerName <server_hostname>
        DocumentRoot /usr/local/apache/htdocs
        ServerAdmin <admin_email>
        <IfModule mod_suphp.c>
            suPHP_UserGroup nobody nobody
        </IfModule>
    </VirtualHost> 
    
    I would guess that <main_shared_IP> is wrong.
     
Loading...

Share This Page