Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

problem with my first plugins

Discussion in 'cPanel Developers' started by whm-expert, May 24, 2013.

  1. whm-expert

    whm-expert Active Member

    Joined:
    Nov 10, 2012
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    DataCenter Provider
    hello
    i am creating my first plugins in whm
    i only want to print my company name and logo,
    this is the contain of my "addon_phplogo.cgi"
    /usr/local/cpanel/whostmgr/docroot/cgi/addon_phplogo.cgi
    ===================================
    #WHMADDON:phplogo:company logo
    print "my name";
    ===================================
    i can see the page in plugins section in whm but when i click on the page i see this error
    -------------------------------------------------------------------------------
    Internal Server Error
    500
    No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/addon_phplogo.cgi): subprocess exited with status 127
    -------------------------------------------------------------------------------

    so can anyone help me to solve this problem?
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,384
    Likes Received:
    1,951
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Could you paste the full contents of the CGI file that you have created? Or, is what you posted the exact line by line file?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. whm-expert

    whm-expert Active Member

    Joined:
    Nov 10, 2012
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    DataCenter Provider
    thank you for your reply, i solve the problem
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,384
    Likes Received:
    1,951
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    I am happy to hear you were able to resolve the issue. Would you mind sharing the resolution in the event other users experience a similar error and find this thread?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice