problem with mysql on restored process from cpmove file

urgido

Well-Known Member
Jul 19, 2005
129
10
168
cPanel Access Level
Root Administrator
When an account is restored completely from WHM as root mysql service becomes inactive. I found many sites had problems connecting to mysql including my WHMCS system.

This error only occurs when WHM is preparing to restore the backup cpmove.

It's a normal issue?
Anybody can confirm this as same problem?
 

24x7server

Well-Known Member
Apr 17, 2013
1,911
96
78
India
cPanel Access Level
Root Administrator
Twitter
Hello,

Do you notice any specific error messages while restoring your account backup ? Please update here that logs, so that we can check it and assist you on this.
 

urgido

Well-Known Member
Jul 19, 2005
129
10
168
cPanel Access Level
Root Administrator
Thanks for your reply.
You can perform this by yourself.
Replicate these steps:
1.- Restore an account from WHM as root.
2.- In the restoring process, visit any website using mysql (you'll see connection problems to database)

what log do you want?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Hello :)

What's the output to /var/lib/mysql/$hostname.err when this happens?

Thank you.
 

urgido

Well-Known Member
Jul 19, 2005
129
10
168
cPanel Access Level
Root Administrator
My log is very large and I don't have the exact day of this issue. But if you want, you can try by yourself.
If this occurs again I will update this thread
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
You can review /var/cpanel/accounting.log to determine when an account was created, and then search around that time in /var/lib/mysql/$hostname.err since you mentioned the issue happens when an account is in the process of restoring.

Thank you.