The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Mysql

Discussion in 'General Discussion' started by rorobobo, May 24, 2006.

  1. rorobobo

    rorobobo Active Member

    Joined:
    Dec 9, 2005
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    I have a problem with mysql, mysql don't function and when i start or restart mysql, i have error :

    /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)' Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists! mysql has failed, please contact the sysadmin (result was "Warning, no valid mysql.sock file found.mysql has failed").

    Can you help me ?

    Regards
     
  2. Ricky

    Ricky Registered

    Joined:
    May 24, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem, please reply as soon as possible!!
     
  3. robdog

    robdog Member

    Joined:
    May 24, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I think this was from the auto update that happened last night.

    Is the solution upgrading to MySql 4.1? Rolling back to an older version of cPanel?

    I am having the same problem.
     
  4. Ricky

    Ricky Registered

    Joined:
    May 24, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    It was already on 4.1 but I changed it to 5.0 :( How do I back roll a older cPanel version?
     
  5. rorobobo

    rorobobo Active Member

    Joined:
    Dec 9, 2005
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Ok...

    And i want to stop the problem, how ??? And i don't want to delete all the database to stop the problem.

    Regards
     
  6. Ricky

    Ricky Registered

    Joined:
    May 24, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Run this following command through SSH; su mysql -c "/usr/sbin/mysqld" that'll run mySQL. :)
     
  7. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    You need to be very careful with up/downgrading MySQL. You might end up with empty or corrupted databses. Keep backup of your MySQL DBs all the time, just in case. Look into the log files for any errors that might help in troublshooting the problem.
     
  8. rorobobo

    rorobobo Active Member

    Joined:
    Dec 9, 2005
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    I think to reinstall mysql but how save all the databases, i don't access nothing database, acces denied...

    Can you help me to reinstall mysql without delete database ?
     
  9. trinity1511

    trinity1511 Member

    Joined:
    Aug 29, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Backup


    To backup your mysql databases you need to backup /var/lib/mysql folder into a tar archive.
    First stop MySQL, then go to SSH and type

    Code:
    tar -czf mysql_db_backup.tar.gz /var/lib/mysql
    And proceed to do your upgrade/downgrade....
     
  10. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    You know, you never really say anyting thats very important in your posts. Howabout solutions and help? Seems like your posting just for the hell of it. Are you still trying to drum up more business by having people click on the servertunes.com icons in your signature? I know, this has not helped you very much in the past in the EV1 forums as most of your business is not from there. So you continue to reply to posts here because it seems to get you more business. But in reality, your posts are completely unhelpful with no meat behind them. Howabout this, if you going to reply to a post, try to help out instead of just trying to make your presence known,

    Get a life Andy!
     
    #10 jackie46, Jun 1, 2006
    Last edited: Jun 1, 2006
  11. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider

    Enough with the personal bashing. If you do not like someones posts feel free to ignore. Personal attacks are grounds to be banned from the forum.
     
  12. kemis

    kemis Well-Known Member

    Joined:
    Feb 17, 2005
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Georgetown, TX
    I had this same problem, too, when I woke up this morning and realized that my MySQL was auto-updated to 4.1.19 last night. No current posts really helped much, except that I saw I wasn't alone. Others kept suggesting the "Old old 4.0 passwords" options, but I already had that set and changing it on and off didn't help.

    Going to WHM --> Change a User or Database Password and resetting my mysql root password back to my usual worked for me.

    All is well again, I believe.

    -- Matt
     
Loading...

Share This Page