Problem with passing throught login

mikesta

Member
Oct 30, 2008
16
0
51
Hi,
I just tried to write my own joomla cpanel bridge to login and it works fine so far, but there is one problem left, I would need your help.

I tried different ways but finally made a simple redirect to

Code:
http://SERVER:2082/login?user=Username&pass=Password
with the necessary username and password. The problem is that I get an Site with that warning:

Access Denied

Functions in cPanel / WHM are available only directly through the cPanel and WHM interfaces or through our XML API. It appears that this request is coming from a referring site and might be malicious. Administrator Note: If new ips were recently bound to this server manually you must restart cpsrvd.
There users have to click the button to move on. So is there a way to allow reffering to a special domain or something else, so that users get directly to their cpanel account without logging in?

Or has someone an idea how the cookie has to be build to enable an direct login?
 

mikesta

Member
Oct 30, 2008
16
0
51
Hi, thanks I already had a look at that script.

The problem is that I have installed my login page at an .org domain and the cpanel server is located at the .com url.

So even with your script, I am getting that warning. Seems that it is because of the different IP´s of the two URL´s.

Any idea on that?
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Hi, thanks I already had a look at that script.

The problem is that I have installed my login page at an .org domain and the cpanel server is located at the .com url.

So even with your script, I am getting that warning. Seems that it is because of the different IP´s of the two URL´s.

Any idea on that?
Are both IPs on the same server? If yes, have you attempted to restart cpsrvd as recommended by the error message?
 

mikesta

Member
Oct 30, 2008
16
0
51
Hi, sorry for the delay.

The two domains are hosted on different servers with different IP´s. But I already found a solution.

It is a bit a work around but I just redirected the login to a second login script that is located directly on my cpanel server and so the problem is gone now. By clicking a link from my Joomla member area my customers are now directly redirected and logged into their Cpanel accounts.

Thanks for the help.