The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with php.ini local value

Discussion in 'General Discussion' started by brumie, Oct 14, 2006.

  1. brumie

    brumie Active Member

    Joined:
    Dec 9, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    i just upgrade to latest stable and running easyapache using option 6 and selecting the phpsuexec + php 5.1.6

    before i use 5.1.6 i can simply put php.ini to enable register_global = On
    was worked but now it won't read the local value php.ini
    offcoz i don't use php_flags/value in .htaccess since php run as cgi mode

    my question, what's is wrong with the easyapache 5.1.6 option 6 can't read php.ini local value??
    here's my phpinfo: http://www.superpowerserver.com/diagnostics/
    here's a sample php.ini http://www.superpowerserver.com/diagnostics/php.ini

    status still
    register_globals (local value) Off (Master value) Off

    should be
    register_globals (Local value) On (Master value) Off


    UPD:
    /configure [@php-5.1.6]...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --with-curl --enable-exif --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --with-imap=/usr/local/imap-2004g --enable-mbstring --enable-mbstr-enc-trans --enable-mbregex --with-mcrypt --with-mhash --enable-magic-quotes --with-mysqli --with-mysql=/usr --with-snmp --enable-ucd-snmp-hack --with-openssl --enable-discard-path --with-pear --with-pgsql=/usr --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --with-xmlrpc --with-zip --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . Done

    when i'm trying to recompile again, on that stage above, i tried to check the phpinfo result:
    register_globals (Local value) On (Master value) Off

    but after done the installation it goes back again to
    register_globals (local value) Off (Master value) Off

    weird tho, easyapache i select the default no.2 with default 4.4.3 the php.ini local value is working
    arrghhh any help?

    thanks in advance
     
    #1 brumie, Oct 14, 2006
    Last edited: Oct 14, 2006
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
  3. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Short answer: the fact that local php.ini files once worked was a bug. This bug has since been fixed.

    Shame really, since it's a very useful bug.
     
Loading...

Share This Page