The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with PHP setup.

Discussion in 'General Discussion' started by charris456, Sep 25, 2011.

  1. charris456

    charris456 Registered

    Joined:
    Sep 25, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,

    I am having a problem with accounts being able to upload files via POST. FTP works fine and so does uploading the file through the file manager.

    I have the following setup:
    CloudLinux
    LiteSpeed
    SuExec PHP

    I have made sure the POST/File Upload limits in the php.ini are more than enough, and I have turn open_basedir off. After that I thought it could be a permissions error since I wasn't able to chmod folders through ftp and I ran the commands and scripts here :
    /http://piyecarane.wordpress.com/2008/08/19/fixing-file-and-folder-permission-on-suphp/
    and it allowed me to chmod folders, but still didn't allow me to upload files.

    I noticed this problem after installing wordpress and trying to upload a theme this is the error returned: The uploaded file could not be moved to /home/junixhos/public_html/wp-content/uploads/2011/09.

    Anyone have any ideas on what I can try next?

    Thanks!
     
  2. harshala21

    harshala21 Registered

    Joined:
    Nov 28, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Check to make sure that the permissions for /wp-content/uploads/ has been set 777.

    You can also check the default folder for uploading has been set to /wp-content/uploads/. Its at Settings > Miscellaneous.

    Else try to recreate the "uploads" folder from /wp-content/ ie delete the /uploads/ folder and re-create it & set the permission to 777. This also works for many users.

    Or then Append this code to your .htaccess file and check:
    SecFilterEngine Off
    SecFilterScanPOST Off
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    194
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    There is no reason to set directories to 777 with a SuPHP setup, ignore that post above.

    charis456, that article you link to is over 3 years old and appears to be incorrect. You should contact your host, or put in a ticket to cPanel Support from WHM > Support > Support Center > Contact cPanel and ask them if they can help.
     
Loading...

Share This Page