The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with php upgrade

Discussion in 'EasyApache' started by moriel pahima, Sep 11, 2016.

  1. moriel pahima

    moriel pahima Registered

    Joined:
    Sep 11, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    israel
    cPanel Access Level:
    Root Administrator
    hi everyone
    i have a server that runs whm & cpanel
    i need to upgrade the php version to 5.3.29
    the current version is 5.2.17
    im using the easyapache 3 for the upgrade
    iv'e tried to upgrade with a "half success"
    when i run php -v command it shows 5.3.29
    but with phpinfo (php file) its stuck on 5.2.17.
    like nothing changed and apps that requires php 5.3+ wont run.
    i also tried upgrading to 5.4 then downgrade but with no success
    its very urgent and me and the hosting company can figure it out.
    we also tried with new apach configuration no success
    even with an apach upgrade (2.2 to 2.4)
    help plz :)
    thank a lot!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Please post the output from the following command:

    Code:
    /usr/local/cpanel/bin/rebuild_phpconf --current
    Also, have you verified the domain name you are running the PHPINFO file on resolves to the cPanel server? Do you utilize any custom php.ini files within this account?

    Thank you.
     
  3. moriel pahima

    moriel pahima Registered

    Joined:
    Sep 11, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    israel
    cPanel Access Level:
    Root Administrator
    hi
    thanks for your reply
    no custom php.ini
    domain resolves same server.

    before running that command i need to upgrade my php again to 5.3.29
    i will upgrade and the run that command.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature if the issue persists. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page