Problem with PowerDNS (nameserver) start after reboot.

peterk

Member
Mar 22, 2019
9
1
3
Poland
cPanel Access Level
Root Administrator
Hello,

I have a problem with PowerDNS always after rebooting the server the service does not start immediately.

I receive an e-mail with information about it:

Code:
(XID qhh73n) The “pdns” service is down.
The subprocess “/usr/local/cpanel/scripts/restartsrv_named” reported error number 255 when it ended.
After about 5 minutes I am informed that the service has been launched.
"The service “nameserver” is now operational."

Code:
The 'pdns' service passed the check: pdns (/usr/sbin/pdns_server --guardian=no --daemon=no --disable-syslog --log-timestamp=no --write-pid=no) is running as named with PID 1245 (systemd+/proc check method).
What could be the reason for this?

- Peter.
 

peterk

Member
Mar 22, 2019
9
1
3
Poland
cPanel Access Level
Root Administrator
I do test with rebboot right now, below times of system emails. Messages are received after restart.

17:41 - Login to WHM (information from LFD)
17:46 - Error message (The service “nameserver” appears to be down.)
17:51 - Information about the launch of pdns (The service “nameserver” is now operational.)

Immediately after logging in, when I check the status of services in WHM and PowerDNS, the status is "pending" for about 3-4 minutes (like all services) and right after this time status change to "down" and i got email with information about this error, and few minutes after service (pdns) starting (last email).
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 

haruasato

Registered
Aug 4, 2020
4
0
1
Philippines
cPanel Access Level
Root Administrator
hi lauren, i have same issue but different error.

Service Status

failed ⛔

Notification

The service “nameserver” appears to be down.

Service Check Method

The system’s command to check or to restart this service failed.

Number of Restart Attempts

8

Service Check Raw Output

(XID rakc3v) The “named” service is down.

The subprocess “/usr/local/cpanel/scripts/restartsrv_named” reported error number 255 when it ended.

Startup Log

Aug 04 22:39:28 ns3148318.ip-151-106-38.eu systemd[1]: Starting Berkeley Internet Name Domain (DNS)...
Aug 04 22:39:28 ns3148318.ip-151-106-38.eu bash[14878]: /etc/named.conf:25: expected IP match list element near ';'
Aug 04 22:39:28 ns3148318.ip-151-106-38.eu systemd[1]: named.service: control process exited, code=exited status=1
Aug 04 22:39:28 ns3148318.ip-151-106-38.eu systemd[1]: Failed to start Berkeley Internet Name Domain (DNS).
Aug 04 22:39:28 ns3148318.ip-151-106-38.eu systemd[1]: Unit named.service entered failed state.
Aug 04 22:39:28 ns3148318.ip-151-106-38.eu systemd[1]: named.service failed.
 

philbean

Registered
Jul 14, 2020
3
0
1
UK
cPanel Access Level
Root Administrator
Mine started doing this today too.

Logged into root to see a popup at the top saying there'd been a software update and I needed to reboot.
Graceful Reboot... Checked service status to see all services back up and running except PowerDNS which was down. Got the same email as the OP.

Spend half an hour playing with things. Restaring the DNS etc.. No joy. Always seemed to fail. So logged out and just left it.

25 mins later gets an email saying (The service “nameserver” is now operational.)
 

tommyxv

Member
Jun 15, 2006
17
4
153
Hi,

I am having a similar issue. When I restart the server in WHM, 4 of my sites do not come back online and 1 does. Weird.


2020-08-17_14-51-03.jpg

I have powerdns enable in WHM.

2020-08-17_14-52-05.jpg

I'm not sure what is this means. I saw it posted here so I checked it.


2020-08-17_14-48-21.jpg

Do I have something configured wrong?
 

cPanelHB

Technical Analyst
Staff member
Sep 6, 2018
42
7
83
Houston
cPanel Access Level
Root Administrator
Hello,

For anyone with the problem of PowerDNS not auto-starting on boot (triggering one service down notification), this issue was caused during the initial cPanel install. On your system, PowerDNS is likely just not configured to start on boot up.

This is now fixed for new installs:

Fixed case CPANEL-33616: Fix scripts/setupnameserver to install the DNS service at the correct time during initial system installation.
For anyone currently affected, the fix is simply to enable the service to start on boot.

The easiest method (if you are not familiar with the command line) is to use the WHM » Service Manager interface to disable, and then re-enable the DNS server.

To do this, you'll want to un-check the two checkboxes next to "DNS Server", click save at the bottom of the page. Then, go back to the page, check the two check boxes, and save again.

We also have an upcoming fix to make sure this gets done during the maintenence phase of upcp, under case number CPANEL-34225.

For anyone experiencing multiple service down notifications in a row, your problem is unrelated to this, and you should probably contact support.

I hope this information has been helpful.
 
  • Like
Reactions: cPanelLauren