The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with primary dns

Discussion in 'Bind / DNS / Nameserver Issues' started by scislaghi, Feb 8, 2004.

  1. scislaghi

    scislaghi Registered

    Joined:
    Feb 8, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Milan, Italy
    Hello,

    This is my first experience with cpanel. I've done to read docs, faqs and many posts on forum, but I still getting a problem with primary dns. I'm using an external dns, so I've run 'Establish a Trust Relationship with a Primary Nameserver', and this works ok. In fact on remote primary dns i can see in /root/.ssh the file authorized_keys with pub key of host runs WHM. Then, go to create a user, during process of creation system said:

    Added DomainAlias Entry
    Added Named Entry
    Added Named File
    Permission denied, please try again.
    Permission denied, please try again.
    Permission denied (publickey,password,keyboard-interactive).
    Permission denied, please try again.
    Permission denied, please try again.
    Permission denied (publickey,password,keyboard-interactive).
    Permission denied, please try again.
    Permission denied, please try again.
    Permission denied (publickey,password,keyboard-interactive).
    Permission denied, please try again.
    Permission denied, please try again.
    Permission denied (publickey,password,keyboard-interactive).
    Permission denied, please try again.
    Permission denied, please try again.
    Permission denied (publickey,password,keyboard-interactive).
    Added Remote Named File


    So, i've checked log on dns server but no connections was done and also no connections with permission denied. I've checked ssh config and it's ok....

    So what's can be the problem?

    Thanks

    Stefano
     
  2. oscarvs

    oscarvs Registered

    Joined:
    Oct 8, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I have the very same problem here and I can't find a solution.

    please help

    thanks
     
  3. scislaghi

    scislaghi Registered

    Joined:
    Feb 8, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Milan, Italy
    Solvede

    So,

    now seems to be solved. By hand I've checked ssh config both cpanel host and primary nameserver host to use pub key.

    Now I've to change some part in script generates dns zone to suit my debian dns server...

    Bye
     
  4. netwrkr

    netwrkr Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Same problem. I'm interested in your fix. cPanel support has been less than helpful.
     
  5. netwrkr

    netwrkr Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    This is a real show stopper for me. Because WHM can't create the entry on the master dns server it also doesn't create it on the slave dns server. Therefore my resellers are creating new accounts thinking everything is setup yet no dns.

    Any ideas or thoughts are appreciated!

    TP
     
  6. mgphoto

    mgphoto Active Member

    Joined:
    Jan 4, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I've got this same problem plus all my dns has disappeared on my slave servers.

    I don't know what has happened but now there is no dns between the master and the slaves plus I can't add any domains.

    Anyone got a fix for this?

    cPanel.net Support Ticket Number: 40169
     
Loading...

Share This Page