Problem with PureFTPD after upgrade

jfreak53

Well-Known Member
Feb 29, 2008
58
0
56
Ok, so I upgraded yesterday to WHM version 11.28.87, current release version. The upgrade went fine, it went ahead and upgraded PureFTP and Exim while it was at it.

So after the upgrade FTPD won't start, and here is the error I am getting:

Starting pure-config.pl: Running: /usr/sbin/pure-ftpd -O clf:/var/log/xferlog --daemonize -A -c50 -B -C8 -D -E -fftp -H -I15 -lextauth:/var/run/ftpd.sock -L2000:8 -m4 -p30000:50000 -s -U133:022 -u100 -i -Oxferlog:/usr/local/apache/domlogs/ftpxferlog -k99 -Z -Y1 -JHIGH:MEDIUM:+TLSv1:!SSLv2:+SSLv3
/usr/sbin/pure-ftpd: error while loading shared libraries: requires glibc 2.5 or later dynamic linker
[FAILED]
Starting pure-authd: /usr/sbin/pure-authd: error while loading shared libraries: requires glibc 2.5 or later dynamic linker
Now my provider of the VPS says they are unable to fix this and they need to reinstall my container and that I have to backup all my clients accounts and they will trash it. Well that's easily two days downtime, that is not possible.

Any ideas as to what caused this problem and a way to fix it?
 

lijeeshsd

Active Member
Apr 22, 2005
33
0
156
Is it only pureftpd down or the entire VPS?
 

jfreak53

Well-Known Member
Feb 29, 2008
58
0
56
No it was just PureFTPD, I got it fixed running

/scripts/ftpup pureftpd --force

But I still don't know why it would have done it since it originally installed from CPANEL upgrader. But it's working now, thanks.