Yogesh Singh

Member
Nov 10, 2014
9
0
1
Ghaziabad, INDIA
cPanel Access Level
Root Administrator
I have tried everything but none of the solution is working so contacting support. Allow me to explain my issue.

I updated to the latest version of cPanel which is v11.46.0 (build 12) the next day it was available. Since then i am having problem with quotas, the quotas are showing unlimited for all accounts. I have tried to rebuild Quota from Server Configuration >> Initial Quota Setup but no luck. It shows the below results:

Code:
Installing Default Quota Databases......Done
journaled quota support: kernel supports, user space tools supports (available)
checking out /home/backup/
checking out /backup
checking out /backup
Warning : Your system does not have a separate filesystem for backups. This may cause performance degradation during the backup process.
/dev/md1 (already configured quotas = 1).
Quotas will not be enabled on /home to prevent performance degradation.
/dev/md2 (already configured quotas = 0).
Updating Quota Files......
quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

....Done
Quotas have been enabled and updated.
Reading package Starter
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 100 M
Reading package Power
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 25600 M
Reading package Prox
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 15360 M
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 25600 M
Reading package Advanced
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 1024 M
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 0 M
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 100 M
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 1024 M
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 100 M
Now, I have also tried (reference http://forums.cpanel.net/f5/frustrating-quota-error-centos-6-2-xen-260462.html) i.e.

To check to see if "/dev/root" exists: ll /dev/root
If it does not exist, try linking "/dev/xvda" to it via: ln -s /dev/xvda /dev/root
Then, ran the following command: # /scripts/fixquotas

And, followed this too: /http://www.daftspunk.com/code/fix-for-file-system-quotas-devroot-symlink-breaks-linode-centos-6-x

But no luck. Please help.
 

lorio

Well-Known Member
Feb 25, 2004
305
16
168
cPanel Access Level
Root Administrator
Are you using a VPS under Xen? Could be CentOS 6.6 update. Since that came in the same timerange than 11.46 release.

I got your error on a cpanel dnsonly too. What do you get with uname -a ?
 

Yogesh Singh

Member
Nov 10, 2014
9
0
1
Ghaziabad, INDIA
cPanel Access Level
Root Administrator
Also, i am receiving this email notification daily.

Sub: Output from your job 45

repquota: Cannot stat() mounted device /dev/root: No such file or directory
repquota: Cannot stat() mounted device /dev/root: No such file or directory
repquota: Cannot stat() mounted device /dev/root: No such file or directory
repquota: Cannot stat() mounted device /dev/root: No such file or directory
repquota: Cannot stat() mounted device /dev/root: No such file or directory
repquota: Cannot stat() mounted device /dev/root: No such file or directory

Not sure what is happening. Any help is highly appreciated.
 
Last edited:

lorio

Well-Known Member
Feb 25, 2004
305
16
168
cPanel Access Level
Root Administrator
Its a dedicated server from OVH.
Linux hostname.domain.com 3.10.23-xxxx-std-ipv6-64 #1 SMP Tue Mar 18 14:48:2
4 CET 2014 x86_64 x86_64 x86_64 GNU/Linux
What OS? It looks to me not like a plain CentOS 6.X installation.

It looks more like a OVH dedicated with a OVH custom kernel.

You should ask OVH about there custom kernel and problems with CentOS 6.6 (if that is what you are running).
I don't see a widespread problem related to cpanel but to kernel flavour and used OS.

The vanilla kernel for CentOS 6 is currently 2.6.32-504.el6.x86_64 #1 SMP Wed Oct 15 04:27:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Please post the output from the following commands in CODE tags:

Code:
cat /etc/fstab
mount
Thank you.
 

Yogesh Singh

Member
Nov 10, 2014
9
0
1
Ghaziabad, INDIA
cPanel Access Level
Root Administrator
Thank you for taking interest in solving this issue.

For cat /etc/stab
Code:
cat: /etc/stab: No such file or directory
For mount
Code:
rootfs on / type rootfs (rw)
/dev/root on / type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
devtmpfs on /dev type devtmpfs (rw,relatime,size=32968872k,nr_inodes=8242218,mode=755)
none on /proc type proc (rw,nosuid,nodev,noexec,relatime)
none on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
/dev/md2 on /home type ext4 (rw,relatime,data=ordered)
tmpfs on /dev/shm type tmpfs (rw,relatime)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
/dev/loop0 on /tmp type ext3 (rw,nosuid,noexec,relatime,errors=continue,barrier=1,data=writeback)
/dev/loop0 on /var/tmp type ext3 (rw,nosuid,noexec,relatime,errors=continue,barrier=1,data=writeback)
/dev/root on /home/virtfs/earpeace/lib type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/lib type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/bin type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/bin type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/sbin type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/sbin type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/opt type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/opt type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/lib64 type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/lib64 type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/usr type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/usr type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/var type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/var/spool type ext3 (rw,nosuid,noexec,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/var type ext3 (ro,nosuid,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/var/log type ext3 (rw,nosuid,noexec,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/var/spool type ext3 (rw,nosuid,noexec,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/etc/mail type ext3 (rw,nosuid,noexec,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/var/log type ext3 (rw,nosuid,noexec,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/loop0 on /home/virtfs/earpeace/tmp type ext3 (rw,nosuid,noexec,relatime,errors=continue,barrier=1,data=writeback)
/dev/loop0 on /home/virtfs/earpeace/var/tmp type ext3 (rw,nosuid,noexec,relatime,errors=continue,barrier=1,data=writeback)
/dev/root on /home/virtfs/mmaol/etc/mail type ext3 (rw,nosuid,noexec,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
devtmpfs on /home/virtfs/earpeace/dev type devtmpfs (rw,nosuid,noexec,relatime,size=32968872k,nr_inodes=8242218,mode=755)
/dev/root on /home/virtfs/earpeace/usr/sbin type ext3 (ro,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/loop0 on /home/virtfs/mmaol/tmp type ext3 (rw,nosuid,noexec,relatime,errors=continue,barrier=1,data=writeback)
/dev/root on /home/virtfs/earpeace/usr/local/cpanel/3rdparty/mailman type ext3 (ro,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/loop0 on /home/virtfs/mmaol/var/tmp type ext3 (rw,nosuid,noexec,relatime,errors=continue,barrier=1,data=writeback)
/dev/root on /home/virtfs/earpeace/usr/local/cpanel/3rdparty/mailman/logs type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/usr/local/cpanel/3rdparty/mailman/locks type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/earpeace/usr/local/cpanel/3rdparty/mailman/lists type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
devtmpfs on /home/virtfs/mmaol/dev type devtmpfs (rw,nosuid,noexec,relatime,size=32968872k,nr_inodes=8242218,mode=755)
/dev/root on /home/virtfs/earpeace/usr/local/cpanel/3rdparty/mailman/qfiles type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/usr/sbin type ext3 (ro,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/md2 on /home/virtfs/earpeace/home/earpeace type ext4 (rw,relatime,data=ordered)
/dev/root on /home/virtfs/mmaol/usr/local/cpanel/3rdparty/mailman type ext3 (ro,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/usr/local/cpanel/3rdparty/mailman/logs type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/usr/local/cpanel/3rdparty/mailman/locks type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/usr/local/cpanel/3rdparty/mailman/lists type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/root on /home/virtfs/mmaol/usr/local/cpanel/3rdparty/mailman/qfiles type ext3 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=writeback,jqfmt=vfsv0,usrjquota=quota.user)
/dev/md2 on /home/virtfs/mmaol/home/mmaol type ext4 (rw,relatime,data=ordered)
 

Yogesh Singh

Member
Nov 10, 2014
9
0
1
Ghaziabad, INDIA
cPanel Access Level
Root Administrator
My fault, apologies for wasting your time. Please find the required results below:

Code:
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/md1        /       ext3    errors=remount-ro,usrjquota=quota.user,jqfmt=vfs                                                                             v0      0       1
/dev/md2        /home   ext4    defaults        1       2
/dev/sda3       swap    swap    defaults        0       0
/dev/sdb3       swap    swap    defaults        0       0
/dev/sdc3       swap    swap    defaults        0       0
proc            /proc   proc    defaults                0       0
sysfs           /sys    sysfs   defaults                0       0
tmpfs           /dev/shm        tmpfs   defaults        0       0
devpts          /dev/pts        devpts  defaults        0       0
 
Last edited:

Yogesh Singh

Member
Nov 10, 2014
9
0
1
Ghaziabad, INDIA
cPanel Access Level
Root Administrator
Anything else you need?

Also, OVH said:
Will have to check with our dev team to see if there are any known issues on our end. If anything, we'll contact cPanel and see what issues they have detected.

Like I said however, I will check with our development guys if there are any known issues with the CentOS kernel or cPanel.
 

Adrian Costin

Registered
Nov 19, 2014
1
0
1
Romania
cPanel Access Level
DataCenter Provider
First, regarding the following error:

Code:
repquota: Cannot stat() mounted device /dev/root: No such file or directory
Please do a:

Code:
ls -l /dev/root
and make sure it's a link to "md1". If that's not the case then that needs to be fixed.

I also see that your /home partition (/dev/md2) doesn't have quota activated. You need to edit /etc/fstab and add the quota parameters for /dev/md2 exactly as /dev/md1. The final line should read like this:

Code:
/dev/md2        /home   ext4    errors=remount-ro,usrjquota=quota.user,jqfmt=vfs        1       2
After you edit the line you need to remount the partition using these options like this:

Code:
mount -o remount,usrjquota=quota.user /dev/md2
Then check the mount command and verify that /dev/md2 is now mounted with the quota options. If it does, run /scripts/fixquotas again and check if you still receive errors.
 
Last edited by a moderator:

jhio

Member
Nov 3, 2005
6
0
151
Hi!! thank you for your post. It helped me to solve the same issue. I have a question 'tough..
You said to write down the same mounting options for '/' to '/home' , so my new fstab looks like this:

Code:
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/sda2       /           ext3    errors=remount-ro,usrjquota=quota.user,jqfmt=vfsv0      1       1
/dev/sda3       /home   ext4    errors=remount-ro,usrjquota=quota.user,jqfmt=vfsv0       1       2
/dev/sda4       swap    swap    defaults        0       0
proc            /proc   proc    defaults                0       0
sysfs           /sys    sysfs   defaults                0       0
tmpfs           /dev/shm        tmpfs   defaults,noexec,nosuid,nodev,noatime    0       0
devpts          /dev/pts        devpts  defaults        0       0
/usr/tmpDSK             /tmp                    ext3    loop,noexec,nosuid,nodev,noatime 0 0
Is there any consideration about mounting /home as 'errors=remount-ro' ?

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello,

The use of "errors=remount-ro" indicates it will remount as read-only if the system encounters errors. You are welcome to change that value, but cPanel/WHM and services will already not function if the primary partition (/) is in read-only mode.

Thank you.
 

tomidjx

Registered
Nov 14, 2013
4
0
1
cPanel Access Level
Root Administrator
Hi, I've a similar problems as above.
My output for cat /etc/fstab is:
#
# /etc/fstab
# Created by anaconda on Sun Mar 9 13:40:48 2014
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/xvda / ext4 noatime,errors=remount-ro,usrjquota=quota.user,jqfmt=vfsv0 0 1
/dev/xvdb none swap sw 0 0
tmpfs /dev/shm tmpfs nodev,nosuid,noexec,mode=1777 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
/proc /proc proc defaults 0 0
/usr/tmpDSK /tmp ext3 defaults,noauto 0 0
Could you please give advice?
Thanks
 

tomidjx

Registered
Nov 14, 2013
4
0
1
cPanel Access Level
Root Administrator
Hi,
in my cPanel in the List Account page I get Unlimited as a value on the "Quota" column, although I've set a specific quota value per each account.
Furthermore, some accounts shows 0 on the "disk used" column (still on the list account page), some other show a very low value (such as 3MB or so), which I believe are not correct.

This is a fairly new install of cPanel (version 11.52.0 build 22), installed few weeks ago.
Centos 6.5

I tried to run # /scripts/fixquotas and i got this out put:
Warning : Your system does not have a separate filesystem for backups. This may cause performance degradation during the backup process.
/dev/xvda (already configured quotas = 1).
Updating Quota Files......
quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

....Done
Quotas have been enabled and updated.
Reading package agrituri600
Resetting quota for agritur2015 to 600 M
edquota: Cannot stat() mounted device /dev/root: No such file or directory
No filesystems with quota detected.
cat /etc/fstab give this output:
# /etc/fstab
# Created by anaconda on Sun Mar 9 13:40:48 2014
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/xvda / ext4 noatime,errors=remount-ro,usrjquota=quota.user,jqfmt=vfsv0 0 1
/dev/xvdb none swap sw 0 0
tmpfs /dev/shm tmpfs nodev,nosuid,noexec,mode=1777 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
/proc /proc proc defaults 0 0
/usr/tmpDSK /tmp ext3 defaults,noauto 0 0
# mount give this output:
# mount
/dev/xvda on / type ext4 (rw,noatime,errors=remount-ro,usrjquota=quota.user,jqfmt=vfsv0)
/proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/usr/tmpDSK on /tmp type ext3 (rw,noexec,nosuid,loop=/dev/loop0)
/tmp on /var/tmp type none (rw,noexec,nosuid,bind)
Thanks for your attention