The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Remote Database Access Hosts

Discussion in 'Database Discussions' started by santrix, Mar 27, 2010.

  1. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    18
    This is a new installation, and is in production. Everything appears to be fine, but the Remote Database Access Hosts is not working correctly. When we add a hostname to the list for any account (whether logged in as root, or as the user) it does not get added to the host list, even though it seems to take effect (i.e. the external host gains access).

    Any idea what's up? Where are the config files for this on the server so i can check what's going on?

    Cheers
     
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    You will have to add the IP address of the remote machine in your cpanel from where you are trying to access the database. You will have to add the IP address in cPanel --> Remote MySQL.
     
  3. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    18
    That's what I have done already... it's the main server hostname that trying to access mySQL... this might sound odd, but the reason it works this way is because I am connecting using SSH tunnel to the server, and then the SSH service is piping the connection through to mySQL.
     
  4. handsonhosting

    handsonhosting Well-Known Member

    Joined:
    Feb 17, 2002
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Omaha, NE
    cPanel Access Level:
    Root Administrator
    Any resolve on this?

    If add IP nubmers from inside the cPanel, it says added successfully but the
    page still says "There are no additional mysql access hosts configured"

    If I add the actual name provided by the clients ISP (cpe-xxx-xxx-xxx-xxx.carolina.res.rr.com) it returns saying that the hostname is not valid.

    If I put "cpe%" or just "%" is says that it's added to the list but doesn't show on the page.

    Still no remote access.

    Downgraded from CURRENT-45479 to RELEASE-44718, get the same results.
     
Loading...

Share This Page