The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Reseller's Shared IP... No IPs Available...

Discussion in 'General Discussion' started by goodbot, Apr 19, 2014.

  1. goodbot

    goodbot Member

    Joined:
    Jan 29, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Florida
    cPanel Access Level:
    Root Administrator
    I'm just setting up a new cPanel environment. I've created a few resellers. I've assigned each of them their own IP, and I've designated this IP as their sharing IP for the new accounts they set up. When I log into a reseller's account and attempt to create a new user account, I get the error message:

    Code:
    Account Creation Status: failed
    
    Your system has run out of available ip addresses, or you do not have permission to use any more ip addresses. (Unable to find an ip address.)
    
    In WHM (root), Resellers/Manage Reseller's IP Delegation/ in Restricted Delegation I'm showing the desired shared IP checked off and it reads:

    Code:
    123.123.123.123 (reseller01's shared IP)(Shared by reseller01.)(Delegated to reseller01.)
    
    I've tried a number of userland/gui hacks to no avail. Any ideas?
     
  2. goodbot

    goodbot Member

    Joined:
    Jan 29, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Florida
    cPanel Access Level:
    Root Administrator
    Re: Problem with Reseller's Shared IP... No IPs Available... RESOLVED!

    RESOLVED!

    Here's the scoop... When setting up a new account, one of the steps you come to requires you to select a package... there's a checkbox option to "Select Options Manually"... I was NOT checking this because I just created the packages a short time earlier and I knew there was nothing in there that needed review or changing... WRONG!!

    Within the package details the option "Dedicated IP" was checked. When I went through the account setup procedure again and this time checked the "Select Options Manually" box, the available options displayed expanded to now show me that the Dedicated IP box was checked... by simply unchecking this and proceeding, the account then setup successfully using the Reseller's dedicated shared IP (as I wanted).

    Going back over my list of packages now, I'm finding that half of them have the Dedicated IP option set, the other half don't. I didn't want that option set on any package, so I'm a bit perplexed that this point got past me 5 or 6 times in setting up the packages. Also, I'm seeing that in 2 or 3 of the packages with the Dedicated IP option set, when reviewing it during this Account Setup routine described above... the Dedicated IP checkbox is shown as being selected... but it's grayed out (not focusable/not selectable), so the Dedicated IP option cannot be unselected.

    This is the next thing I need to investigate... that I apparently need to fix in several of my defined packages. I'll start off by squashing/deleting them... rebuilding them and seeing if this fixes these Dedicated IPs that keep showing as selected.

    Anyway... my first problem here is resolved!!
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I am happy to see the issue was resolved. Note that you can edit an existing package via:

    "WHM Home » Packages » Edit a Package"

    Thank you.
     
  4. cPanelPeter

    cPanelPeter Technical Analyst III
    Staff Member

    Joined:
    Sep 23, 2013
    Messages:
    569
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Glad you solved the problem. Thank you for updating this thread with your solution.
     
Loading...

Share This Page