The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Service Status

Discussion in 'General Discussion' started by Bob Weston, Oct 18, 2009.

  1. Bob Weston

    Bob Weston Member

    Joined:
    Oct 18, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I am having a problem with the service status reporting falsely that EXIM has failed. If I restart EXIM it shows it running but the Service Status always shows red (see attached screenshot).

    Here is the history as to how this happened and I am hoping it is nothing big and someone can help me.

    My /var partition is to small (10gb) and cannot handle all the databases in /var/lib/mysql so I decided I would symbolic link it to /home/var.

    I copied the entire /var directory over to /home and was about to softlink it and thought to myself.. I do not need to softlink the entire directory, just the mysql directory. I w2as in the /home directory and wanted to delete the files I had just copied over from /var and made a mistake and deleted the entire /var instead of /home/var (it is amazing what one extra / in the command line does). This disabled my entire WHM and all websites immediately!

    So, I copied all the files back from /home/var to /var. This also did not work the best because all the permissions were screwed up (everything owned by root), so I spent hours checking permissions from one of my other linux boxes and changing them appropriately.

    So knowing all this info, what am I missing here to get this status to show correctly? The service is running correctly:


    root@server5 [~]# service exim restart
    Shutting down clamd: [ OK ]
    Shutting down exim: [ OK ]
    Shutting down spamd: [ OK ]
    Starting clamd: [ OK ]
    Starting exim: [ OK ]
    Starting exim-smtps: [ OK ]
    root@server5 [~]#


    I appreciate any help.

    Bob
     

    Attached Files:

  2. Bob Weston

    Bob Weston Member

    Joined:
    Oct 18, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I hadn't checked my mail and am also getting emails stating that EXIM failed and could not be restarted, it states this being the reason:

    << 535 Incorrect authentication data
    exim: ** [535 Incorrect authentication data != 2]

    what would I have to do to fix this? I already ran /scripts/eximup --force

    Thanks,
    Bob
     
  3. Bob Weston

    Bob Weston Member

    Joined:
    Oct 18, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    OK, since I am talking to myself here I will post this information because I have resolved this issue myself. If anyone else has this problem here is how to fix it:

    cd /var/cpanel/serviceauth/
    rm -rf exim
    /scripts/upcp --force

    with this you are deleting the exim folder out of /var/cpanel/serviceauth/

    when you run cpanel up it will reinstall it and fix the issue.

    Bob
     
Loading...

Share This Page