GoWilkes

Well-Known Member
Sep 26, 2006
561
21
168
cPanel Access Level
Root Administrator
I'm having a rather weird problem (I think) with writing Sessions.

Quick background: I'm moving a site to a new server, and for now have the domains on the old server proxied to the new server, using mod_proxy in Apache. The session files are written to a /tmp directory that is partitioned with a 1G limit. The site has been proxied to the new server for 2 days now.

Both days, at approximately 1:30am, it looks like all sessions start writing files that are 0 bytes in size. This results in several thousand empty files.

Further, it looks like the /tmp directory reaches the 1G limit (I get an email saying that it's at 100%), but then when I SSH to the directory, it only has about 4MB worth of data in it.

One (or both) of these issues end up resulting in an error for the user, stating that /tmp/sess_[whatever] isn't available. The only way I've found to resolve it is to completely reboot the server.

Any suggestions on what may be causing this, or what I might do to stop it?

TIA,

Jason
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello Jason,

Is there any user or root level cron that runs at 1:30am on the machine? Since it seems to happen around the same times, that sounds like something that could be cron-based causing it.

Next, have you checked for Apache traffic during that time to see if there is any strange traffic going on for the site? You would need to view the domlogs for the domain at /usr/local/apache/domlogs/domain.com location to check for that.

Additionally, I'd highly suggest creating a cron to list the files in /tmp during that period of time and run a "df -kh" on it every minute around that time. This way you can see what is going on at that time in case you do miss it.

Thanks!
 

GoWilkes

Well-Known Member
Sep 26, 2006
561
21
168
cPanel Access Level
Root Administrator
As far as I can tell, there aren't any crons set up outside of the default crons. Under /var/spool/cron, I don't see anything that references /tmp, but I do see that cpbackup is set to run daily at 1am.

Could cpbackup being filling up the /tmp directory? I've disabled it for now.